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1 Introduction to the HPE Matrix Operating Environment
This document provides an overview of HPE Matrix Operating Environment (HPE Matrix OE).
•

Chapter 1 describes the product features and the available configurations.

•

Chapter 2 (page 17) describes the licensing model and license management procedures.

•

Chapter 3 (page 25) describes initial setup steps to get started with HPE Matrix OE.

•

Chapter 4 (page 39) describes the tools available to set up managed systems correctly and
diagnose and correct common configuration problems.

•

Chapter 5 (page 43) provides a list of support resources and a comprehensive list of HPE
Matrix OE documentation.

•

The Command reference (page 50) provides command reference pages for the vseassist(1M)
and vselicense(1M) commands that are mentioned elsewhere in this document.

•

The Glossary (page 61) provides definitions of key terms used in this document. If you are
viewing this document in electronic form, click the term to jump to the glossary definition.

HPE Matrix OE is an integrated command center that enables you to continuously analyze and
optimize your cloud and converged infrastructure. It builds on the Hewlett Packard Enterprise
infrastructure management portfolio, including HPE Systems Insight Manager (HPE SIM) and
HPE Insight Management.
HPE Matrix OE provides an integrated graphical environment for managing physical servers,
logical servers, virtual machines, server blades, nPartitions, virtual partitions, applications, and
workloads. You can dynamically resize virtual servers and migrate resources where they are
needed, based on service-level objectives and business requirements.
For information about the changes in this release of HPE Matrix OE, see the HPE Matrix Operating
Environment Release Notes available at Hewlett Packard Enterprise Information Library. For
a complete list of HPE Matrix OE documentation and the websites where these documents can
be found, see “Related information” (page 45).
IMPORTANT: The information in the following sections is a summary. Specific supported
hardware and software configurations are provided in the HPE Insight Management Support
Matrix, available at Hewlett Packard Enterprise Information Library.

Components of HPE Matrix OE
The HPE Matrix OE software is installed on a Central Management Server (CMS) running HPE
SIM, which provides a browser-based user interface. A single CMS can be used to manage
different types of systems or instances.
The Matrix OE components include:
•

HPE Capacity Advisor

•

HPE Matrix OE visualization

•

HPE Matrix OE infrastructure orchestration

•

HPE Matrix OE recovery manager

•

HPE Storage provisioning manager

•

HPE Global Workload Manager

•

HPE Application Discovery

Components of HPE Matrix OE
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The software is installed on the CMS once, regardless of how many or what types of managed
system or managed instance licenses are purchased. The following CMS installations are
supported:
•

HPE Matrix OE can be installed on the following types of CMS running Microsoft Windows:

◦

HPE ProLiant server

◦

HPE BladeSystem c-Class ProLiant server blade

◦

Virtual machine running under VMware ESX or Microsoft Hyper-V on HPE ProLiant or
supported non-Hewlett Packard Enterprise server

On a CMS running Microsoft Windows, HPE Matrix OE is installed as part of the HPE Insight
Management software family of products. For installation and configuration information, see
the HPE Insight Management Preinstallation Worksheet, HPE Insight Management Quick
Installation Guide, and HPE Insight Management Installation and Configuration Guide. For
an introduction to HPE Insight Management software, including security recommendations,
a summary of included products, and a documentation roadmap, see the HPE Insight
Management Getting Started Guide available at Hewlett Packard Enterprise Information
Library.
Table 2 (page 14) provides information on the HPE Matrix OE features that are available
on a CMS running Microsoft Windows.
•

HPE Matrix OE can be installed on the following types of CMS running HP-UX:

◦

HPE Integrity server

◦

HPE Integrity server blade

◦

Virtual machine running under HP-UX vPars and Integrity VM

For installation on a CMS running HP-UX, see the HPE Matrix Operating Environment
Integrity CMS Installation and Configuration Guide available at Hewlett Packard Enterprise
Information Library.
Table 3 (page 16) provides information on the HPE Matrix OE features that are available
on a CMS running HP-UX.
The following sections summarize the major software components of HPE Matrix OE. For more
information, see the user guides and other documents listed in “Related information” (page 45).
Help is also available within the software by clicking the
most screens.

button in the upper right corner of

HPE Matrix OE visualization
HPE Matrix OE visualization provides the framework for visualizing and managing your server
environment (including virtual servers, physical servers, and logical servers). All the systems and
workloads, that you are authorized to view, are displayed in graphical view. You can view the
hierarchical relationships between systems and their current utilization metrics in a single screen.
With HPE Matrix OE visualization, you can perform the following tasks:
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•

Customize the level of detail that you want to see.

•

Easily access additional HPE Matrix OE capabilities to manage and configure systems and
workloads.

•

Inventory your virtual and physical servers.

•

Centrally configure your server resources for optimum utilization.

•

Manage logical servers and storage pool entries.

Introduction to the HPE Matrix Operating Environment

Launch HPE Matrix OE visualization from HPE SIM in any of the following ways:
•

From the top (HPE SIM) menu bar, select Tools→HPE Matrix OE visualization....

•

From the Systems and Event Collections list in the left navigation area, select
Systems→Shared→Systems by Type→All Matrix OE Resources, or expand the All
Matrix OE Resources collection by clicking its icon, then selecting a subset such as
nPartitions.

•

Create a custom collection whose default view is set to “HPE Matrix OE visualization”,
and then select that collection in the left navigation area.

For more information about HPE Matrix OE visualization, see “Using HPE Matrix OE visualization”
(page 29).

HPE Matrix OE logical server management
A logical server is a set of configuration information that you create, activate and move across
physical and virtual machines. It contains the logical server definition and description, including
the server compute resources (for example, number of CPU cores and amount of memory), and
the server connections to storage fabric and networks.
A logical server is managed within HPE Matrix OE visualization and, when activated, is applied
to the creation of a virtual machine using hypervisor-based software or to a bare-metal server
blade using HPE Virtual Connect Enterprise Manager. Logical servers can be defined using the
Create Logical Server wizard, or created and activated via the import of an existing server blade
or virtual machine.
Logical server management is only supported on a CMS running Microsoft Windows.
The Logical Servers feature in HPE Matrix OE visualization allows you to perform tasks such as
the following:
•

Populate an enclosure

•

Load-balance servers

•

Evacuate servers, for routine maintenance or in case of disaster

Using logical servers within HPE Matrix OE visualization provides the following benefits:
•

Allows you to use a common interface and management tools for both virtual machines and
server blades.

•

Allows you to deploy resources only when needed. For example, some applications are
needed only during parts of a business cycle.

•

Increases business agility and flexibility by decoupling business processing from physical
hardware, allowing you to respond to rapid changes in demand.

•

Reduces downtime required for physical system maintenance, whether planned or unplanned.

•

Allows for server consolidation and improved server utilization, which help to maximize
limited compute resources.

For more information, see the HPE Matrix Operating Environment Logical Server Management
User Guide available at Hewlett Packard Enterprise Information Library.

HPE Capacity Advisor
HPE Capacity Advisor helps you to analyze and optimize workloads across your management
domain to maximize utilization of computing resources.
It consists of two tools, Capacity Planning and Capacity Analysis:
•

Capacity Planning provides scenario analysis to help manage your current server resources
and plan for changes to your workloads and computing environment (system CPU and
Components of HPE Matrix OE

7

memory, network and disk I/O bandwidth, and power use). It lets you quickly and safely test
proposed configuration changes in your data center before you actually make them.
•

Capacity Analysis combs through utilization data to help you locate both immediate and
impending problems in the data center.
Predefined queries allow you to monitor resource utilization on network systems over a
period of time. You can also define new, custom queries. When creating or editing queries,
you can define the information to be listed in a query's results, thereby creating a customized
report.

With HPE Capacity Advisor, you can find answers to questions such as the following:
•

Is there room on this system for an additional workload?

•

Will this workload fit on this system?

•

Can I consolidate these servers as virtual machines on a single server?

•

What might my resource demand be in six months or a year?

•

What are the estimated power costs for cooling a real or simulated system configuration?

•

What does a comparison of several what-if scenarios reveal about the analyzed alternatives?

You can launch HPE Capacity Advisor in any of the following ways:
•

Select Tools from the top menu bar, and then select Capacity Analysis... or Capacity
Planning....

•

Select Optimize from the top menu bar, and then select Capacity Analysis... or Capacity
Planning....

•

Select Tools→HPE Matrix OE visualization from the top menu bar, and then click the
Analysis tab or the Planning tab.

For more information about HPE Capacity Advisor, see the HPE Capacity Advisor User Guide,
available at Hewlett Packard Enterprise Information Library.

HPE Capacity Advisor Consolidation software
HPE Capacity Advisor is also available through a limited-duration license for systems that are
intended to be consolidated. Using this software, you can collect data to help plan the consolidation
of existing systems without requiring a permanent HPE Matrix OE license for the systems.
The HPE Capacity Advisor Consolidation software license includes the following restrictions:
•

This license does not include HPE Matrix OE visualization or any other HPE Matrix OE
components.

•

Systems with this license are not included in the analysis performed by the Capacity Analysis
tool.

For more information, see “Data collection and the HPE Capacity Advisor Consolidation software”
in the HPE Capacity Advisor User Guide.

HPE Matrix Operating Environment infrastructure orchestration
HPE Matrix infrastructure orchestration provides rapid provisioning and repurposing of
infrastructure services from shared resource pools using a self-service portal. HPE Matrix OE
infrastructure orchestration delivers advanced template-driven design, provisioning, and ongoing
operations for multi-node, multi-tier infrastructure services. It is only supported on a CMS running
Microsoft Windows.
HPE Matrix OE infrastructure orchestration supports four main activities to automate the
deployment of infrastructure services:
Design
8
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An architect uses the graphical designer to create simple and complex infrastructure templates
that, when tested, can be published for users to create infrastructure services.
Provision
A self-service user selects an existing template and then requests infrastructure provisioning
from it, against an assigned pool of resources. The administrator can approve or deny this request
and monitor its progress.
Operate
The administrator manages server, network, and storage pools, defines virtual machine images
and software deployment jobs, performs manual provisioning tasks as part of the fulfillment of
self-service requests, and uses HPE Insight Management software to monitor the health and
utilization of the managed environment.
Integrate
Architects and administrators integrate infrastructure orchestration with existing IT processes by
modifying or creating HPE Operations Orchestrations workflows to customize the HPE Matrix
infrastructure orchestration automation. The HPE Operations Orchestration engine is embedded
in HPE Matrix Operating Environment . Using HPE Operations Orchestration Studio, you can
create custom workflow processes and attach them to infrastructure service templates at
well-defined points in the Matrix provisioning process, such as during pre- and post-provisioning
of infrastructure components.
For example, architects and administrators can:
•

•

•

Create a service or add a server:

◦

Add new servers to a cluster or add servers for load balancing.

◦

Add a server to a backup service.

◦

Send approval notices.

Remove a server or service:

◦

Gracefully shut down applications and the operating system.

◦

Remove a server from a cluster or load balancing.

◦

Suspend server monitoring.

Resume a server or service:

◦

Add a server to a cluster or load balancing.

◦

Resume server monitoring.

For information about what is covered in the limited operations orchestration license, see “HPE
Operations Orchestration limited license” (page 20).
For more information about HPE Matrix OE infrastructure orchestration, see the list of documents
under “Related information” (page 45).
For information on provisioning resources to a public cloud service in HPE Matrix OE infrastructure
orchestration, see “Hybrid cloud management licensing” (page 23).

HPE Matrix Operating Environment recovery management
HPE Matrix OE recovery management provides simplified disaster recovery of logical servers
and HPE Matrix OE infrastructure orchestration services. With a mouse click, you can transfer
application environments running on HPE BladeSystems or on virtual machines to a remote
recovery site. Logical servers and HPE Matrix OE infrastructure orchestration services (IO
Components of HPE Matrix OE
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services) that are included in a HPE Matrix OE recovery management configuration are referred
to as DR Protected logical servers and IO services.
A HPE Matrix OE recovery management configuration consists of two sites, each managed by
the HPE Matrix Operating Environment. The site where the CMS you are logged into is referred
to as the Local Site, and the other site in the HPE Matrix OE recovery management configuration
is referred to as the Remote Site. HPE Matrix OE recovery management pairs symmetrically
configured logical servers or IO services across the two sites. One logical server or IO service
in the pair is activated at one site, while the other ( peer logical server or IO service) is deactivated
at the other site. The boot images of these DR Protected logical servers and IO services, including
applications code and data, reside on SAN volumes. The source volumes at the site where one
of the logical servers or IO services in the pair is activated are replicated at the other site where
its peer logical server or IO service is deactivated.
These volumes are part of a Storage Replication Group that uses storage array supported
replication. One or more logical servers or IO services can be associated with a single Storage
Replication Group – this is referred to as a Recovery Group.
Recovery Groups can be failed over from one site to the other site in a HPE Matrix recovery
management configuration. For example, if a disaster occurs at the Local Site, the administrator
at the Remote Site can trigger a failover for all the Recovery Groups that were activated at the
Local Site by activating them at the Remote Site. This prepares the storage associated with the
deactivated DR Protected logical servers and IO services at the Remote Site for read-write
access, and activates those logical servers and IO services.
HPE Matrix OE recovery management is only supported on a CMS running Microsoft Windows.
For more information, see the HPE Matrix Operating Environment Recovery Management User
Guide available at Hewlett Packard Enterprise Information Library.

HPE Storage Provisioning Manager
HPE Storage Provisioning Manager (HPE SPM) is a software solution that provides a
service-centric management interface to storage, allowing storage requests to be fulfilled with
available storage services from a storage catalog. It securely automates storage management
tasks alongside the HPE Matrix OE visualization software. After storage policies and storage
resources are input to the storage catalog using the HPE SPM user interface, you can use the
HPE Matrix OE logical server management to request and have storage set up to meet server
needs.
For more information, see the HPE Storage Provisioning Manager (SPM) User Guide, the HPE
Matrix Operating Environment Infrastructure Orchestration User Guide, and HPE Matrix Operating
Environment Logical Server Management User Guide available at Hewlett Packard Enterprise
Information Library.

HPE Application Discovery
HPE Application Discovery helps you identify and learn about the applications and processes
running in your data center or computing network.
With HPE Application Discovery, you can do the following:
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•

Discover the location and number of recognized, running, and installed applications in your
network or data center.

•

Monitor the activity and resource usage of running processes and applications.

•

Define and adapt application templates to your environment for better discovery of your
third-party and custom applications, and to make them available for adding to monitored
workloads.

•

Select the event types for which you want to receive notifications and set their level of
importance.

Introduction to the HPE Matrix Operating Environment

For more information about HPE Application Discovery, see the HPE Application Discovery User
Guide, available at Hewlett Packard Enterprise Information Library.

HPE Global Workload Manager (gWLM)
This application improves both workload performance and resource utilization in a shared
computing environment. For servers partitioned with nPartitions, virtual partitions, virtual machines,
PSETS, or FSS groups, HPE gWLM can do the following:
•

Monitor each application.

•

Determine the CPU resources needed by each application.

•

Automatically migrate CPU resources between partitions to where they are needed most.
This migration improves application performance by making more resources available to
the application at times of peak demand. In addition, migrating idle resources to the
applications that are busy increases processor utilization.

To access HPE gWLM from the HPE Matrix OE visualization screen, click the Shared Resource
Domain tab or select one of the items under Tools→Global Workload Manager from the HPE
Matrix OE visualization menu bar.
For more information about HPE gWLM, see the HPE Global Workload Manager User Guide,
available at Hewlett Packard Enterprise Information Library.

HPE Instant Capacity software
The HPE Instant Capacity Manager (HPE iCAP Manager) is a web-based interface that can be
used to monitor your HPE Instant Capacity environment. There are several screens available in
HPE iCAP Manager, including an overview of the HPE Instant Capacity resources available, a
HPE Global Instant Capacity (GiCAP) group manager screen to provide more insight into the
group managers, and detail screens for GiCAP groups and HPE Instant Capacity complexes
and hosts.
You can get to HPE iCAP Manager in either of the following ways:
•

From the HPE Matrix OE Visualization tab, click the HPE Instant Capacity technology link
associated with any managed system that has HPE Instant Capacity components, TiCAP
capacity, or is a member of a GiCAP group.

•

Select Tools→Instant Capacity Manager from the HPE Matrix OE visualization menu bar.

For more information about HPE Instant Capacity software, see the HPE Instant Capacity Manager
Online Help.

Partition Manager
Partition Manager provides system administrators with a convenient graphical user interface to
configure and manage nPartitions on Hewlett Packard Enterprise servers. Using Partition Manager,
you can perform configuration tasks without having to remember commands and parameters.
You select nPartitions, cells, I/O chassis or other components from the graphical display, then
select an action from a menu.
You can use Partition Manager to perform the following tasks:
•

Create, modify and delete nPartitions.

•

Examine the nPartition configuration of a complex.

•

Check the complex for potential configuration and hardware problems.

•

Manage hardware resources on the complex.

For more information about Partition Manager, see the Partition Manager help.

Components of HPE Matrix OE
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HPE Integrity Virtual Server Manager
HPE Integrity Virtual Server Manager is the GUI that you can use from your browser to manage
Integrity VM resources. HPE Integrity Virtual Server Manager allows you to create, configure,
and evaluate virtual machines, and monitor and evaluate data and resources at the level of the
VM Host. You can view all the VM Host's virtual machines and their assigned resources, and
you can view all resources assigned to a specific virtual machine or virtual switch. For example,
HPE Integrity Virtual Server Manager provides graphical views of virtual-to-physical network and
storage devices so that you can view I/O data, including resource utilization information. HPE
Integrity Virtual Server Manager obtains information about Integrity VM resources through
Web-Based Enterprise Management (WBEM) providers installed on the VM Host.
For more information about HPE Integrity Virtual Server Manager, see the HPE Integrity Virtual
Server Manager User Guide, available at Hewlett Packard Enterprise Information Library.

Product configurations
The software is installed on a CMS running HPE SIM, which provides a browser-based user
interface. A single CMS can be used to manage different types of systems. The software is
installed on the CMS once, regardless of how many or what types of managed system licenses
are purchased. Licenses for the managed systems are maintained on the CMS.
For additional information about licensing, see “License management” (page 17).
IMPORTANT: This table is a summary. Specific supported hardware and software configurations
are provided in the HPE Insight Management Support Matrix, which is available at Hewlett
Packard Enterprise Information Library.
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Table 1 Matrix OE software
Matrix OE software

Managed systems supported

CMS platform

• HPE ProLiant servers running
Microsoft Windows or Linux
• HPE BladeSystem c-Class
ProLiant Server Blades running
Microsoft Windows or Linux
HPE Matrix OE for ProLiant

• Virtual machines and VM hosts
running under VMware ESX,
VMware ESXi, or Microsoft
Hyper-V on HPE ProLiant hosts
• Virtual machines and VM hosts
running under VMware ESX,
VMware ESXi, or Microsoft
Hyper-V on selected non-Hewlett
Packard Enterprise hosts

HPE Matrix OE for Integrity

• HPE ProLiant server running
Microsoft Windows
• HPE BladeSystem c-Class ProLiant
Server Blade running Microsoft
Windows
• Virtual machine running Microsoft
Windows running under VMware
ESX or Microsoft Hyper-V on HPE
ProLiant or selected non-Hewlett
Packard Enterprise host

• HPE ProLiant server running
• HPE Integrity servers running
Microsoft Windows
HP-UX, HPE OpenVMS, Integrity
Linux, or Microsoft Windows for
• HPE BladeSystem c-Class ProLiant
Integrity
Server Blade running Microsoft
Windows
• HPE Integrity Server Blades
running HP-UX, OpenVMS,
• Microsoft Windows virtual machine
Integrity Linux, or Microsoft
running under VMware ESX or
Windows for Integrity
Microsoft Hyper-V on HPE ProLiant
or selected non-Hewlett Packard
• nPartitions running HP-UX,
Enterprise host
Integrity Linux, or Microsoft
Windows for Integrity
• HPE Integrity server running HP-UX
• Virtual machines running under
• HPE Integrity Server Blade running
Integrity VM
HP-UX
• Virtual partitions running under a • HP-UX virtual machine running
vPars monitor
under Integrity Virtual Machines

HPE Matrix OE features
The specific features supported by HPE Matrix OE depend on the type of CMS on which the
software is running.
•

Table 2 (page 14) summarizes the features supported for different types of managed systems
using a CMS running Microsoft Windows.

•

Table 3 (page 16) summarizes the features supported for different types of managed systems
using a CMS running HP-UX.

HPE Matrix OE features
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Table 2 Matrix OE features on Windows CMS
Feature

Managed systems/instances supported

Visualize and monitor physical and virtual resources and • HPE ProLiant servers running Microsoft Windows or
workloads using Matrix OE visualization
Linux
• HPE BladeSystem c-Class ProLiant Server Blades
running Microsoft Windows or Linux
• Virtual machines and VM Hosts running under VMware
ESX, VMware ESXi, or Microsoft Hyper-V on HPE
ProLiant and supported non-Hewlett Packard
Enterprise servers
• HPE Integrity servers running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity
• HPE Integrity server blades running HP-UX, Integrity
Linux, or Microsoft Windows for Integrity
• Virtual machines running under Integrity VM
• Virtual partitions running under a vPars monitor
Perform capacity analysis and planning using HPE
Capacity Advisor

• HPE ProLiant servers running Microsoft Windows or
Linux
• HPE BladeSystem c-Class ProLiant Server Blades
running Microsoft Windows or Linux
• Virtual machines and VM Hosts running under VMware
ESX, VMware ESXi, or Microsoft Hyper-V on HPE
ProLiant and supported non-Hewlett Packard
Enterprise servers
• HPE Integrity servers running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity
• HPE Integrity server blades running HP-UX, Integrity
Linux, or Microsoft Windows for Integrity
• Virtual machines running under Integrity VM
• Virtual partitions running under a vPars monitor
• Servers licensed for HPE Capacity Advisor
1
Consolidation software

Visualize and monitor logical servers server profiles that • HPE BladeSystem c-Class ProLiant Server Blade
2
can be easily created and freely moved
running Microsoft Windows
• Virtual machines running Microsoft Windows under
VMware ESX, VMware ESXi, or Microsoft Hyper-V on
HPE ProLiant and supported non-Hewlett Packard
Enterprise servers
• HPE Integrity server blades running HP-UX, Integrity
2
Linux, or Microsoft Windows for Integrity
• Virtual machines running under Integrity VM
Provision logical servers using HPE Matrix infrastructure • HPE BladeSystem c-Class ProLiant Server Blades
3
2
orchestration
running Microsoft Windows
• Virtual machines running Microsoft Windows under
VMware ESX, VMware ESXi, or Microsoft Hyper-V on
HPE ProLiant and supported non-Hewlett Packard
Enterprise servers
• HPE Integrity server blades running HP-UX, Integrity
Linux, or Microsoft Windows for Integrity
• Managed instances on an external cloud service, such
as HPE CloudSystem resource pools (8.0, 8.1, and
8.1.2), other HPE Matrix systems, other Hewlett
Packard Enterprise certified bursting destinations, or
14
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Table 2 Matrix OE features on Windows CMS (continued)
Feature

Managed systems/instances supported
Amazon EC2.
• CloudSystem Foundation

Enable site-to-site fault recovery of logical servers using • HPE BladeSystem c-Class ProLiant Server Blades
2
HPE Matrix Operating Environment recovery management
running Microsoft Windows
• Virtual machines running Microsoft Windows under
VMware ESX, VMware ESXi, Microsoft Hyper-V on
HPE ProLiant servers
Identify and monitor running applications and processes • HPE Integrity servers running HP-UX or Integrity Linux4
using HPE Application Discovery
• HPE Integrity server blades running HP-UX or Integrity
4
Linux
• Virtual machines running under Integrity VM
• Virtual partitions running under a vPars monitor
Manage workloads with automated policies using HPE
Global Workload Manager (gWLM)

• HPE Integrity servers running HP-UX
• HPE Integrity server blades running HP-UX
• Virtual machines running under HPE Integrity VM
• Virtual partitions running under a vPars monitor

Manage HPE Integrity virtual machines using HPE
Integrity Virtual Server Manager

• Virtual machines running under Integrity VM
• Integrity Virtual Machine VM hosts

Manage nPartitions and cell-based servers using Partition • HPE Integrity cell-based servers and nPartitions
Manager
Monitor HPE Instant Capacity Manager resources (iCAP, • HPE Integrity servers with HPE Instant Capacity
GiCAP, and TiCAP) using HPE Instant Capacity Manager
Manager products installed
Manage HPE Serviceguard clusters using HPE
Serviceguard Manager

• HPE Integrity servers with HPE Serviceguard installed

1

Analysis queries do not work with HPE Capacity Advisor Consolidation software.

2

Requires HPE Virtual Connect Enterprise Manager on BladeSystem enclosure.

3

If you add customized console links in HPE Matrix infrastructure orchestration, you might need to install the remote
access tool and register the URI protocol, depending on the type of console access desired (such as SSH, VNC, or
RDP). These must be in place before using the customized console links. For more information about defining custom
console links in hpio.properties file, see the HPE Matrix Operating Environment Infrastructure Orchestration User

4

Guide.
Integrity Linux support limited to Red Hat Enterprise Linux 4.x and 5.x and SUSE Linux Enterprise Server 10.x.

HPE Matrix OE features
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Table 3 Matrix OE features on an HP-UX CMS
Feature

Managed systems supported

Visualize and monitor physical and virtual resources and • HPE Integrity servers running HP-UX, Integrity Linux,
workloads using HPE Matrix OE visualization
or Microsoft Windows for Integrity
• HPE Integrity server blades running HP-UX, Integrity
Linux, or Microsoft Windows for Integrity
• Virtual machines running under HPE Integrity Virtual
Server Manager
• Virtual partitions running under a vPars monitor
Perform capacity analysis and planning using HPE
Capacity Advisor

• HPE Integrity servers running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity
• HPE Integrity server blades running HP-UX, Integrity
Linux, or Microsoft Windows for Integrity
• Virtual machines running under HPE Integrity Virtual
Server Manager
• Virtual partitions running under a vPars monitor

Identify and monitor running applications and processes • HPE Integrity servers running HP-UX or Integrity Linux1
using HPE Application Discovery
• HPE Integrity server blades running HP-UX or Integrity
1
Linux
• Virtual machines running under HPE Integrity Virtual
Server Manager
• Virtual partitions running under a vPars monitor
Manage workloads with automated policies using HPE
Global Workload Manager (gWLM)

• HPE Integrity servers running HP-UX
• HPE Integrity server blades running HP-UX
• Virtual machines running under HPE Integrity Virtual
Server Manager
• Virtual partitions running under a vPars monitor

Manage HPE Integrity virtual machines using HPE
Integrity Virtual Server Manager

• Virtual machines running under Integrity Virtual Server
Manager
• HPE Integrity hosts running HPE Integrity Virtual
Machines

Manage nPartitions and cell-based servers using Partition • HPE Integrity cell-based servers and nPartitions
Manager
Monitor HPE Instant Capacity Manager resources (iCAP, • HPE Integrity servers with HPE Instant Capacity
GiCAP, and TiCAP) using HPE Instant Capacity software
Manager products installed
Manage HPE Serviceguard clusters using Serviceguard • HPE Integrity servers with HPE Serviceguard installed
Manager
1
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Integrity Linux support limited to Red Hat Enterprise Linux 4.x and 5.x and SUSE Linux Enterprise Server 10.x.
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2 License management
This chapter describes the licensing models and types of licenses available for HPE Matrix OE,
and explains how to add and apply licenses.

End-user license agreement
If you received HPE Matrix OE as part of your CloudSystem Enterprise Software purchase, then
your right to use HPE Matrix OE is described in the CloudSystem Software license agreement.
If you purchased HPE Matrix OE software, then your right to use of HPE Matrix OE is described
in the HPE Matrix OE software license agreement. Read this document at its installed location
on the CMS:
HP-UX CMS
/opt/vse/src/README
Microsoft Windows CMS

installation-directory\src\README
The default installation directory is C:\Program Files\HP\
Virtual Server Environment, but this directory can be
changed at installation time.

HPE Matrix OE managed system licenses
HPE Matrix OE is licensed for use on managed systems as shown in Table 4 (page 17). Licenses
are managed from the CMS using the HPE SIM License Manager database.

HPE Matrix OE managed system licensing model
Table 4 HPE Matrix OE managed system license requirements
1

System type

License requirement

HPE Integrity Server

License per CPU socket or core

HPE 9000 Server

License per CPU socket or core

HPE ProLiant ML/DL/SL Server

License per system

HPE BladeSystem c-Class enclosure

No enclosure license required or available. Licenses apply
to individual server blades.

HPE BladeSystem c-Class ProLiant Server Blade

License per server blade

HPE Integrity server blade

License per CPU socket or core

Virtual machines running under any of the following:

Covered by host server license

2
2

2

• HPE Integrity Virtual Machines
• VMware ESX
• VMware ESXi
• Microsoft Hyper-V
1

2

The HPE Insight Capacity Advisor Consolidation software license is always licensed per system, regardless of system
type. See “HPE Capacity Advisor Consolidation software license” (page 19).
Trial licenses are licensed per system. See “Managed system trial licenses” (page 20).

NOTE:

Additional product licenses might be required, depending on your installation.

To obtain a permanent License To Use (LTU) for HPE Matrix OE, contact your Hewlett Packard
Enterprise sales representative, your Hewlett Packard Enterprise services representative, or
your authorized Hewlett Packard Enterprise reseller. The available licenses are listed in the
sections that follow.
End-user license agreement
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To use a purchased license, it must be added to the HPE SIM License Manager database on
the CMS and then applied to a managed system.

Licensed HPE Matrix OE products on managed systems
The tables in the following sections summarize the licensed HPE Matrix OE products and the
platforms on which they are available.
For detailed hardware and software configurations supported by HPE Matrix OE, see the HPE
Insight Management Support Matrix, available at Hewlett Packard Enterprise Information
Library.

HPE ProLiant servers and ProLiant server blades
Table 5 Licensed HPE Matrix OE products: For ProLiant servers
License name

Licensed products

Supported OS

HPE Matrix OE for ProLiant

• HPE Matrix OE visualization

• Microsoft Windows

• HPE Capacity Advisor

• Linux

1, 2

3

• HPE Insight Control

• HPE Insight Control virtual
machine management
• HPE Insight Control server
migration
• HPE Insight Control power
management
• HPE Matrix Operating
Environment infrastructure
1
orchestration
• HPE Matrix Operating
Environment recovery
1
management
• HPE Insight Control server
provisioning
1

2

3
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HPE Matrix OE logical server management, HPE Matrix Operating Environment infrastructure orchestration, and HPE
Matrix Operating Environment recovery management are only supported on a CMS running Microsoft Windows.
A license for HPE Virtual Connect Enterprise Manager is required for BladeSystem enclosures to manage logical
servers on server blades.
A license for HPE Insight Control is required. The HPE Insight Control license includes HPE Insight Control virtual
machine management, HPE Insight Control server migration, HPE Insight Control power management, and iLO.

License management

HPE Integrity and HPE 9000 servers and Integrity server blades
Table 6 Licensed HPE Matrix OE products: For Integrity servers
License name
1

HPE Matrix OE for Integrity

Licensed products

Supported OS

• HPE Matrix OE visualization

• HP-UX

• HPE Capacity Advisor
• HPE Global Workload Manager
(gWLM)
• HPE Insight Control virtual
machine management
2, 3, 4

HPE Matrix OE visualization

5

HPE Capacity Advisor

HPE Global Workload Manager
(gWLM)

• HPE Matrix OE visualization

• HP-UX

• HPE Insight Control virtual
machine management

• Microsoft Windows for HPE Integrity

• HPE Matrix OE visualization

• HP-UX

• HPE Capacity Advisor

• Microsoft Windows for HPE Integrity

• HPE Insight Control virtual
machine management

• Linux for HPE Integrity

• HPE Matrix OE visualization

• HP-UX

• Linux for HPE Integrity

• HPE Global Workload Manager
(gWLM)
• HPE Insight Control virtual
machine management

1

2
3

4

5

A license for HPE Matrix Operating Environment infrastructure orchestration for Integrity is included with the HP-UX
VSE and DC Operating Environments.
Includes logical server management, supported on a CMS running Microsoft Windows.
HPE Matrix OE logical server management, HPE Virtual Connect Enterprise Manager, HPE Matrix Operating
Environment recovery management and HPE Matrix Operating Environment infrastructure orchestration are only
supported on a CMS running Microsoft Windows.
A license for HPE Virtual Connect Enterprise Manager is required for BladeSystem enclosures to manage logical
servers on server blades.
A license for Integrity iLO 3 Advanced is recommended to collect advanced power information for visualization meters
and capacity planning.

HPE Capacity Advisor Consolidation software license
The HPE Capacity Advisor Consolidation software license allows you to collect data from systems
that you are planning to consolidate. This license is only needed on managed systems that do
not have a license for HPE Capacity Advisor or HPE Matrix OE. Systems with this license are
not included in the analysis performed by the Capacity Analysis tool.
Table 7 HPE Capacity Advisor Consolidation software license
License name

Licensed products

Supported platforms
1, 2

HPE Capacity Advisor Consolidation HPE Capacity Advisor
software

Servers running HP-UX 11i, Microsoft
Windows for Integrity, x86-based
Microsoft Windows Server, or Linux

1

License is valid for six months after it is assigned to a system.

2

Does not include license for HPE Matrix OE visualization. Systems with only this license will not be visible in visualization.

HPE Matrix OE managed system licenses
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HPE Operations Orchestration limited license
HPE Matrix OE infrastructure orchestration 7.6 includes HPE Operations Orchestration 10.60,
which is an upgrade from the 9.07 version included in the 7.5 release. This version of HPE
Operations Orchestration software is licensed for limited uses. It is launched from HPE Matrix
infrastructure orchestration and used to trigger workflows that can be performed before or after
IO operations.
HPE Operations Orchestration 10.60 requires Operating System Instance (OSI) based license
keys. OSI license keys will be supplied even though HPE Matrix Operating Environment software
is licensed under a per-server license agreement. When installed, it will have a 90–day trial
license, with no difference from the licensed version. If no license is configured by the time the
90 day trial is completed, HPE Operations Orchestration will stop working, and HPE Matrix
features using HPE OO workflows will stop working (including sending emails, managing static
servers, provisioning ESXi clusters, and use of attached workflows for solution customization).
The “Activating and installing HPE Operations Orchestration licenses” (page 21) section discusses
how to activate and install this HPE Operations Orchestration OSI based license.
This restricted version of operations orchestration:
•

Is licensed for only one author. An upgrade to the full version of operations orchestration
allows for multiple authors.

•

Can only be used for pre- and post-provisioning workflows and workflow troubleshooting.
An upgrade to the full version of operations orchestration allows you to schedule the launch
of HPE Operation Orchestration workflows outside of HPE Matrix OE.

•

Provides a subset of the content that is available in the full version of HPE Operations
Orchestration. This subset is related to Infrastructure-as-a-Service workflows. An upgrade
to HPE Helion CloudSystem Enterprise provides unrestricted use of full HPE Operations
Orchestration including additional content through HPE Live Network.

•

Allows HPE Matrix OE to be integrated with other management software. However, this
requires additional services from Hewlett Packard Enterprise consulting.

License requirements for managed systems with HPE Instant Capacity products
For systems using HPE Instant Capacity products (including iCAP, GiCAP, and TiCAP), the total
number of licenses assigned across all nPartitions within the complex (or across multiple
complexes when using GiCAP) must be equal to or greater than the total number of processors
that you have purchased.

Managed system trial licenses
The following trial licenses are available:
•

When HPE Matrix OE is installed on the CMS, 10 trial licenses for HPE Matrix OE for Integrity
are included in the License Manager database. These licenses can be applied to HPE
Integrity and HP 9000 systems. Each trial license is valid for 90 days after it is applied to a
managed system. To continue to manage these systems beyond the trial period, you must
purchase permanent licenses.
These trial licenses can be applied to managed systems by the Insight managed system
setup wizard or by the vselicense command. They cannot be applied through HPE SIM
License Manager. For information about the managed system setup wizard, see
“Recommended process: Use the managed system setup wizard” (page 21). For information
about vselicense, see “Command reference” (page 50).

•
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HPE Matrix OE trial licenses for 10 managed systems can be obtained by registering with
Hewlett Packard Enterprise. To obtain these trial licenses, contact your Hewlett Packard
Enterprise sales representative, your Hewlett Packard Enterprise services representative,
or your authorized Hewlett Packard Enterprise reseller.

License management

You can view the status of your trial licenses using the HPE SIM License Manager. For information
about License Manager, see “Alternative process: Use HPE SIM License Manager” (page 21).

Activating and installing HPE Operations Orchestration licenses
Obtaining an HPE Operations Orchestration license
For new installations, activate your license on My License Portal. Enter the Entitlement Order
Number (EON) which can be obtained from the entitlement certificate delivered with your order
(either electronically or printed). During license activation, you must enter a Locking ID. Enter
the Central Management Server (CMS) IP address when running the bundled HPE OO. HPE
Matrix also supports an external HPE OO configuration, which would be separately licensed.
For upgrades, activate your license on Sign in . Enter the Support Agreement ID (SAID) that
includes HPE Matrix OE software SKUs.

Installing an HPE Operations Orchestration license
1.
2.

3.
4.
5.

Open HPE Operations Orchestration using the URL https://<CMS-IP>:8443/oo.
Log in to the HPE Operations Orchestration administrator account using the following
credentials:
•

User name: admin

•

Password: the HPE Insight Management service account password specified during
the installation

Select System Configuration, then select System Settings, and then click License.
Click Install License.
Browse to license file, and click OK.

Updating an HPE Operations Orchestration license
The HPE Operations Orchestration license is locked by the IP address. In case the CMS IP
address is changed (by using mxreconfig tool), it is necessary to access the customer portal in
order to perform a re-host of the license from the original IP address to the new one.

Adding and applying managed system licenses
To use a purchased license, you must first add it to the HPE SIM License Manager database on
the CMS, then apply the license to a specific managed system. The CMS keeps track of how
many of each type of license are available to be applied to managed systems. As you apply
licenses, the number of available licenses decreases.

Recommended process: Use the managed system setup wizard
Hewlett Packard Enterprise recommends using the HPE Insight managed system setup wizard
to add and apply licenses for HPE Matrix OE. To start the managed system setup wizard, select
Configure→Managed System Setup Wizard... from the top menu bar. Help is available in each
step of the wizard. For more information about the managed system setup wizard, see “Using
the HPE Insight managed system setup wizard” (page 25), and the HPE Insight Managed System
Setup Wizard Getting Started Guide available at HPE Hewlett Packard Enterprise Information
Library.

Alternative process: Use HPE SIM License Manager
If you choose not to use the HPE Insight managed system setup wizard, you can use the HPE
SIM License Manager to add and apply most types of licenses. You can also use License Manager
to view the available and applied licenses for all products in the License Manager database. To
use the License Manager, you must have administrative rights on the CMS.

HPE Matrix OE managed system licenses
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Some licenses cannot be applied through License Manager:
•

Trial licenses can only be applied to managed systems by the Insight managed system setup
wizard or by the vselicense command. For information about vselicense, see “Command
reference” (page 50).

•

LTUs from earlier versions of the VSE Management Software for Integrity or from the HP-UX
VSE or DC operating environments are managed using the vselicense command or the
“Scan for HP-UX Licenses” tool. For more information, see “Scan for HP-UX licenses ”
(page 22).

Setting authorizations
To add and apply licenses, you must have administrative rights on the CMS and you must be
authorized for the All Tools toolbox on the managed systems that you want to license. To assign
administrative rights to an HPE SIM user, select Options→Security→Users and
Authorizations→User. Select the user and click Edit. In the Edit form, select the check box for
User can configure CMS security access such as creating, modifying or removing other
users. To enable the All Tools toolbox for the user, select Options→Security→Users and
Authorizations→Authorizations and click New. In the New Authorizations form, select the
user, the All Tools toolbox, and the system.
Starting the License Manager
To start License Manager, select Deploy→License Manager... from the top menu bar. This
menu selection will only be available if you have administrative rights on the CMS. Online help
is available to guide you through the use of License Manager.
The License Manager lists all the available license types from which you can choose to deploy.
Order for applying licenses—Windows CMS managed systems
For systems that will be managed by a CMS running Microsoft Windows, applying licenses in
the proper order will simplify the process and reduce errors. From the Windows CMS, apply
licenses to each managed system in the order shown for each system type:
HPE BladeSystem c-Class ProLiant 1. HPE iLO Advanced
Server Blade
2. HPE VCEM (enclosure license required for logical
server management of server blades)
3. HPE Insight Control
4. HPE Matrix OE
HPE ProLiant ML/DL/SL server

1.
2.
3.

HPE BladeSystem c-Class Integrity 1.
Server Blade
2.

HPE iLO Advanced
HPE Insight Control
HPE Matrix OE
HPE VCEM (enclosure license required for logical
server management of server blades)
HPE Matrix OE

Scan for HP-UX licenses
From a CMS, use the Scan for HP-UX Licenses task to perform the following functions:
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•

Enable the HPE Matrix Operating Environment for HP-UX licenses that are included in the
HP-UX Operating Environments.

•

Migrate unused licenses that were purchased for an earlier release to the HPE SIM License
Manager database and apply them to your managed systems (if permitted by your licensing
agreement with Hewlett Packard Enterprise).

License management

To launch this task from the License Manager, click Scan for HP-UX Licenses... on the last
Deploy: HPE Matrix OE for Integrity Licenses screen. On the Task Confirmation screen,
click Run Now. Online help is available to guide you through the operation.
This task scans for licenses for any VSE Management Software or HPE Matrix OE for Integrity
LTU that is installed on the managed systems. It is not restricted to the type of license that was
originally selected in License Manager. It only discovers licenses on HP-UX systems, even if
other types of systems were included in the License Manager system selection. For more
information about scanning for HP-UX licenses and migrating unused licenses from earlier
software versions, see “Command reference” (page 50).

Using the CMS password reconfigure tool
The CMS reconfigure tool provides a command that enables you to quickly change passwords
for many licensed systems at once. For information on the CMS reconfigure tool and how to use
the command with the HPE Matrix OE, see the HPE Systems Insight Manager User Guide
available at Hewlett Packard Enterprise Information Library.

Hybrid cloud management licensing
HPE Matrix OE managed environments include all on-premise private cloud resources, as well
as any off-premise (also known as, “public cloud”) resources utilized by HPE Matrix OE template
designs. HPE Matrix OE environments, whether enabled through HPE Matrix OE-specific licenses,
or through HPE Helion CloudSystem Enterprise licenses, cover the management of these blended
hybrid cloud environments.
If you have purchased HPE Matrix OE software or HPE Helion CloudSystem Enterprise, then
the per-server license(s) you purchased entitle you to manage public cloud instances as part of
your HPE Matrix OE environment with no limit on the number of VMs created via bursting.
If you have purchased HPE Helion CloudSystem Enterprise through a per-OSI license model,
then you must continue to track individual provisioning instances, whether the provisioned resource
is on-premise, or off-premise, to ensure that the provisioned environment is in compliance with
the license guidelines.

Bursting to external, off-premise clouds
Public cloud bursting is a feature of HPE Matrix OE that enables enterprises to broker service
delivery across multiple clouds from a single, integrated point of control. With HPE Matrix OE
bursting, enterprises can design, catalog, provision, control, and monitor infrastructure services
uniformly across complex hybrid cloud environments. As a result, businesses can more easily,
safely, and cost effectively supplement internal resources with public cloud resources to meet
extra capacity demands, to extend geographic reach, or to leverage specialized infrastructure
service offerings.
HPE Matrix OE supports the following cloud services:
•

HPE Matrix (Matrix-to-Matrix bursting)

•

Amazon EC2 Web Services

•

HPE CloudAgile certified bursting destinations

•

HPE HelionCloudSystem 8 Resource pools

Resources accessible via these services are represented as Cloud Resources inside HPE Matrix
OE. Cloud Resources can be added to a server pool in the same way as any other VM Host,
ESX Resource Pool, or Hyper-V resource pool.
For information on how to configure HPE Matrix OE for bursting and how to provision to an
external cloud with HPE Matrix infrastructure orchestration, see HPE Matrix Operating Environment
Infrastructure Orchestration User Guide available at Hewlett Packard Enterprise Information
Library.
Hybrid cloud management licensing
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For information on the bursting protocol, see the HPE CloudSystem Matrix Bursting Protocol
white paper available at Hewlett Packard Enterprise Information Library.
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3 Getting started
Installing the software
This document does not cover installation of the software or upgrade from previous versions of
the software. For installation and upgrade on a CMS running Microsoft Windows, see HPE Insight
Management Preinstallation Worksheet, HPE Insight Management Quick Installation Guide, and
HPE Insight Management Installation and Configuration Guide available at Hewlett Packard
Enterprise Information Library. For installation and upgrade on a CMS running HP-UX, see
the HPE Matrix Operating Environment Integrity CMS Installation and Configuration Guide
available at Hewlett Packard Enterprise Information Library.

Configuring privilege elevation
Some HPE Matrix OE management functions require privileged (root) access from the CMS to
HP-UX, Linux, and VMware ESX managed systems. Privilege elevation allows you to use your
preferred mechanism for acquiring root permissions as needed (for example, using sudo or
PowerBroker), without having to allow login through the root account.
Procedure 1 Configuring privilege elevation for use with HPE Matrix OE
1.
2.
3.

Select Options→Security→Privilege Elevation... from the top menu.
Select Enable privilege elevation for Linux and HP-UX (or VMware ESX, according to
the type of managed system OS).
Select the elevation tool type from the menu.
IMPORTANT: HPE Matrix OE does not support the option A password is required for
this privilege elevation tool. Make sure this option is not selected.

4.

Select Use this user and enter a user name to be used to access all managed systems
with this type of operating system. You also must enable the selected user login on the
managed systems.

Additional configuration might also be needed. For example, you might need to configure SSH
access using Configure→Configure or Repair Agents..., and you might need to configure the
managed system to allow host authentication for non-root users. For more information, see the
HPE Systems Insight Manager Help, mxagentconfig(1M), and the HPE Insight Management and
HPE Matrix OE installation and configuration guides. Links to these documents can be found in
“Related information” (page 45).

Using the HPE Insight managed system setup wizard
HPE Insight managed system setup wizard configures systems to enable them to be managed
by HPE SIM and its plug-in applications, including HPE Matrix OE. Use the managed system
setup wizard for initial configuration or re-configuration of any selected set of systems. After you
specify which management features you want to use on the selected systems, the wizard analyzes
the current configuration of each system and performs the following functions:
•

Installs any agents necessary to enable the selected management features.

•

Applies any required licenses from the set of licenses available in the License Manager
database.

•

Completes additional configuration steps required by the features that you selected.

After initial configuration, you can run the managed system setup wizard again at any time to
modify the selected management features and change the configuration.
For more information about the managed system setup wizard, see the HPE Insight Managed
System Setup Wizard Getting Started Guide, available at Hewlett Packard Enterprise
Information Library.
Installing the software
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Configuring user authorizations
Users must be authorized in HPE SIM to use HPE Matrix OE tools and features. Information
about HPE Matrix OE user authorizations is available in the HPE Matrix Operating Environment
Online Help, with additional information provided in the HPE Matrix OE component help.

Configuring data collection credentials
Systems that are to be managed using HPE Matrix OE or simulated for capacity planning and
analysis must be configured to allow data collection from the CMS. In general, data collection
can be enabled either through the Utilization Provider (UP) installed on the managed system, or
through native data collection. For a description of the two methods, see the section “Comparison
of agentless and UP data collection” in the HPE Capacity Advisor User Guide available at Hewlett
Packard Enterprise Information Library.
Authentication is required to enable data collection. The required credentials are summarized in
Table 8 (page 26). You can verify or modify the WBEM or SSH credentials for a system that has
been discovered in HPE SIM by selecting Options→Security→Credentials→System
Credentials... from the top menu bar.
Table 8 Data collection credentials requirements
Managed system OS / Data
Collection Method

Required access credentials

Required access level

HP-UX/Utilization Provider

WBEM credentials must be
configured (or discovered) in HPE
SIM for these systems

Non-root or root

Integrity Windows, (physical server
or VM), from an HP-UX
CMS/Utilization Provider

WBEM credentials must be
configured (and discovered or
identified) in HPE SIM for these
systems

Does not require Administrator level
access

Windows physical server from a
Windows CMS/Agentless

WBEM credentials must be
configured (or discovered) in HPE
SIM for these systems

WBEM login must be a member of the
Administrators group on these systems

x86 Linux physical server or Integrity SSH credentials or certificate-based Non-root or root credentials, or
Linux (physical server or
SSH authentication must be
certificate-based authentication may
VM)/Agentless
configured (or discovered) in HPE
be used
SIM for these systems
Note
On a Windows CMS, any VMware ESX and Microsoft Hyper-V hosts must be properly registered in HPE Insight
Control virtual machine management to allow data collection from these hosts and their virtual machines. For
information about registering the hosts in HPE Insight Control virtual machine management, see HPE Insight Control
Virtual Machine Management User Guide.

About the HPE Capacity Advisor Data Collection Service
In HPE Capacity Advisor, collection of resource usage data is managed by a service. The service
gathers data provided by the Utilization Provider and native data collectors and normalizes it into
five-minute data points. The service starts automatically on installation and runs constantly unless
stopped—providing data for visualizing resource use on discovered systems and workloads and
for capacity planning. When needed, the service can be stopped or restarted on the CMS.
Procedure 2 Windows CMS: Stopping the HPE Capacity Advisor Data Collection Service
1.
2.
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Select Start→Administrative Tools→Services.
In the Name column, look for “HPE Capacity Advisor Data Service.” Right-click on this name
and select Stop.

Getting started

Procedure 3 Windows CMS: Starting the HPE Capacity Advisor Data Collection Service
1.
2.

Select Start→Administrative Tools→Services.
In the Name column, look for “HPE Capacity Advisor Data Service.” Right-click on this name
and select Start.

Procedure 4 HP-UX CMS: Stopping the HPE Capacity Advisor Data Collection Service
•

From the command line as root, run /sbin/init.d/hp_cpdata_service stop

Procedure 5 HP-UX CMS: Starting the HPE Capacity Advisor Data Collection Service
•

From the command line as root, run /sbin/init.d/hp_cpdata_service start

NOTE: The Options→Data Collection menu option (on the top menu bar) allows you to
configure data collection for server inventory only. See “Solving utilization data collection problems”
(page 27) when you suspect resource utilization data is missing or utilization data collection is
not working.

Configuring data metrics to better reflect your environment
HPE Capacity Advisor provides tools for making the data metrics displayed in the visualization
profile viewer and in capacity planning scenarios better reflect your computing environment.
•

From the HPE Matrix OE Visualization tab or the Planning tab, select Configure→Global
Utilization Limits to set default limits for utilization of CPU, memory, and disk and network
I/O bandwidth to better reflect your Service Level Agreement.

•

Determine your expected growth rate, then use Configure→Global Forecast... to realistically
project future utilization.

•

Reflect your business cycle(s) by changing the displayed date range in your scenarios and
observing the peak, sustained, 90th percentile, and average data views.

•

On the Visualization tab, use Configure→Calibrate Power (All Selected Systems)... to
define power settings for your systems. You must have full authorization on the managed
nodes to use this function.

Solving utilization data collection problems
HPE Matrix Operating Environment provides a default Events collection called “Utilization Data
Collection Events.”

About the HPE Capacity Advisor Data Collection Service
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When you suspect you are experiencing a utilization data collection error, review the event listings
available from this menu. To obtain details about an event, including how to address a problem,
click the event type to open the detail table.
To learn more about how to use event collections, click the button to read “Navigating the
event table view page” in the HPE Systems Insight Manager Help.
To learn more about HPE Capacity Advisor functions, see the HPE Capacity Advisor User Guide,
available at Hewlett Packard Enterprise Information Library.

Removing unneeded agent software
If you have upgraded from a previous version of HPE Matrix Operating Environment, there may
be agents installed on some of your managed systems that are no longer needed. This will occur
on managed systems that previously used the Utilization Provider for data collection and are
now configured for agentless or native data collection. The following types of systems are affected:
•

Integrity Linux or x86 Linux managed systems. In releases prior to version 6.0, these systems
needed the Utilization Provider for data collection. In the current release, these systems will
be configured to use agentless data collection. The Utilization Provider is not supported by
HPE Matrix Operating Environment on Linux managed systems.

•

Microsoft Windows managed systems, but only if you are using a CMS that is also running
Microsoft Windows (agentless data collection from Windows systems is not supported on
an HP-UX CMS).

In these cases, when you use the HPE Insight managed system setup wizard to configure the
system, the following message will be displayed:
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Agentless data collection is not configured; it will be configured.
An HP Utilization Provider has been detected; it will not be used
for data collection.
You should remove any sub-OS workloads defined on this system.

NOTE:
Any Windows sub-OS workloads on previous versions where this configuration was supported
are automatically removed during the upgrade of HPE Matrix Operating Environment.
You may choose to remove the Utilization Provider from the affected systems after they have
been configured for agentless data collection.
IMPORTANT: Even though HPE Matrix OE will no longer use the Utilization Provider for data
collection, there may be other software installed on the system that still uses it (for example, HPE
Insight Control power management). Do not remove the agent if it is still in use.
Procedure 6 Remove the Utilization Provider from a Windows Server 2003 system
1.
2.
3.

From Control Panel, select Add or Remove Programs.
Select “HPE WMI Util Provider v1.8.1.1” (or the current installed version).
Click Remove.

Procedure 7 Remove the Utilization Provider from a Windows Server 2008 system
1.
2.
3.

From Control Panel, select Program and Features.
Select “HPE WMI Util Provider v1.8.1.1” (or the current installed version).
Click Uninstall.

Procedure 8 Remove the Utilization Provider from a Linux system
1.
2.

Open a command shell with root privileges.
Execute the following command:
rpm -e hp-utilprovider

For more information about agentless data collection, see the section “Comparison of agentless
and UP data collection” in the HPE Capacity Advisor User Guide available at Hewlett Packard
Enterprise Information Library.

Using HPE Matrix OE visualization
HPE Matrix OE visualization provides features that let you visualize and manage physical and
virtual servers discovered and licensed for use within the HPE Matrix Operating Environment.
Using visualization, you can:
•

Customize the level of detail that you want to see.

•

Easily access additional applications to manage and configure systems and workloads.

•

Inventory your virtual and physical servers

•

Centrally configure your server resources for optimum utilization.

•

Manage logical servers.
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Starting HPE Matrix OE visualization from HPE SIM
Start HPE Matrix OE visualization software from HPE Systems Insight Manager in any of the
following ways:
•

From the blue HPE SIM menu bar, choose Tools→HPE Matrix OE visualization....

The first time you start HPE Matrix OE visualization, the Visualization View appears with the
default Physical and Virtual perspective. This perspective shows all physical and virtual
systems in graphical compartments.
When you start HPE Matrix OE visualization subsequent times, the software checks to see
if you had previously set a default view by modifying the user preferences. If you set a
collection (for example, Blade), HPE Matrix OE visualization displays that collection.
If you create a custom collection and set the custom collection to the default collection, and
you later delete that collection and start HPE Matrix OE visualization using the Tools→Matrix
OE visualization menu selection, a blank screen is displayed if you start HPE Matrix OE
visualization quickly (within a minute or two of deleting the collection). If you wait a minute
or so, the default collection is reset to All Matrix OE Resources. Alternatively, you can enter
HPE Matrix OE visualization through the left side menu and change your preference to an
existing collection.
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•

From the HPE Systems Insight Manager Systems and Event Collections list in the left-hand
navigation area, choose Systems→Shared→Systems by Type→All Matrix OE Resources.

•

From the HPE Systems Insight Manager System and Event Collections list in the left-hand
navigation area, expand the All Matrix OE Resources collection by clicking its icon, then
choose a subset such as nPartitions.

•

Create a custom HPE Systems Insight Manager collection whose default view is set to “HPE
Matrix OE visualization”. Select this collection to start HPE Matrix OE visualization.
This is described in more detail in “Creating custom collections” (page 36). That section also
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describes how to customize HPE Systems Insight Manager to display HPE Matrix OE
visualization automatically as soon as HPE Systems Insight Manager starts.
When you start the HPE Matrix OE visualization from any of the methods listed above, a splash
screen displays as the HPE Matrix OE visualization loads.
NOTE: Do not create multiple browser windows in the same session by using Ctrl-N or
File→New Window in Internet Explorer or Firefox. This results in the same session running in
both windows and causes errors in the HPE Matrix OE visualization. Similarly, do not create
multiple tabs by using Ctrl-T or File→New Tab, which also causes problems. You can, however,
start multiple browsers from the desktop icon or the Start button. In this case, a different session
can run in each browser, which will not cause HPE Matrix OE visualization problems.

HPE Matrix OE tabs
HPE Matrix Operating Environment provides five tabs to move among the capabilities offered
by HPE Matrix OE visualization, HPE Capacity Advisor, and HPE Global Workload Manager:
•

Visualization tab—View a visual representation of all managed servers, their relationships
to each other or to an enclosure, and resource usage data for each server. You can easily
navigate to the management application for each server technology. For more information,
see the online help accessible from the Visualization tab.

•

Workload tab—View workloads in association with their servers and their utilization settings,
within a compact table format. See the online help accessible from the Workload tab.

•

Shared Resource Domain tab—View and manage Shared Resource Domains (SRDs)
using HPE Global Workload Manager (gWLM). gWLM allows you to centrally define
resource-sharing policies that you can use across multiple Hewlett Packard Enterprise
servers. For more information, see the online help accessible from the Shared Resource
Domain tab and see the HPE Global Workload Manager User Guide.

•

Analysis tab—View built-in Capacity Analysis queries that reflect a current concern or
business interest and create custom analysis queries of collected data. For more information,
see the online help accessible from the Analysis tab and see the HPE Capacity Advisor
User Guide available at Hewlett Packard Enterprise Information Library.

•

Planning tab—View computing resource utilization data and create usage scenarios using
HPE Capacity Advisor. For more information, see the online help accessible from the
Planning tab and see the HPE Capacity Advisor User Guide vailable at Hewlett Packard
Enterprise Information Library.

HPE Matrix OE menu bar
The HPE Matrix OE menu bar provides convenient access to the HPE Matrix OE tools and actions
after clicking a HPE Matrix OE tab for a given application.
To perform an action on a system or compartment, select its check box, then choose the menu
selection from the HPE Matrix OE menu bar. Some menu selections (such as Create→Workload
Definition...) do not require you to select a system first.
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NOTE: Menu selections vary between the HPE Matrix OE visualization tabs (Visualization
tab and Workload tab) and the tabs that take you outside the HPE Matrix OE visualization (the
Shared Resource Domain, Analysis, and Planning tabs). The page title indicates the
management application for the selected tab, for example, HPE Matrix OE visualization or
Planning.
Menu selections are disabled if any of the following circumstances exist:
•

A required selection has not been made. For example, Modify→Workload Definition... is
enabled only after you select a workload.

•

Ambiguous selections have been made. For example, if you select more than one workload,
Modify→Workload Definition... is not enabled.
Be sure to select the check box to select the appropriate system or systems before choosing a
menu selection from the HPE Matrix OE menu bar.
The following menu options are available from the HPE Matrix OE menu bar. See the online help
for each menu selection to learn more.
Table 9 HPE Matrix OE visualization Tools menu
Menu selection

Description

Global Workload Manager

Use the Global Workload Manager task screens to define resource-sharing
policies across multiple Hewlett Packard Enterprise servers.

→ Getting Started – gWLM Home
→ Manage Systems and Workloads
→ Edit gWLM Policies
→ gWLM Real-time Reports
→ gWLM Historical Reports
→ gWLM Advanced Reports
→ Events

Virtual Connect Enterprise Manager (VCEM) Use the Virtual Connect Enterprise Manager task screens to manage Virtual
Connect domains.
→ VCEM Homepage
→ Add Virtual Connect Domain to Group
→ Remove Virtual Connect Domain from
Group
→ Virtual Connect Domain Properties
→ Virtual Connect Domain Group Properties
Logical Servers
→ Activate...

Manage logical servers in virtualized environments. Logical server actions are
available from a Windows CMS only.

→ Copy...
→ Deactivate...
→ Import...
→ Move...
→ Refresh...
→ Power
HPE Matrix OE recovery management...

Provides disaster recovery protection for logical servers and IO services
configured and managed by HPE Matrix OE. HPE Matrix OE recovery
management is available on Windows CMS only.

HPE Matrix OE infrastructure management Deploy, manage and monitor the overall behavior of HPE Matrix infrastructure
Service Details
orchestration and its users, templates, services, resources, and organizations.
HPE Matrix infrastructure orchestration is available on Windows CMS only.
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Table 9 HPE Matrix OE visualization Tools menu (continued)
Menu selection

Description

Capacity Planning

Open profile viewers for visualized systems or to create a capacity planning
scenario using HPE Capacity Advisor.

→ View Planning Scenarios...
→ View Capacity Advisor Data...
Process Resource Manager
→ Monitor PRM Groups

Control the amount of computing resources that processes use during peak
system load. Process Resource Manager is available on HP-UX only.

→ Configure PRM Groups
Update System Workloads

Replace all of the monitored workload definitions on the selected managed
system.

Instant Capacity Manager

Monitor all Instant Capacity resources.

Table 10 HPE Matrix OE visualization Create menu
Menu selection

Description

Shared Resource Domain...

Managed systems and workloads defined to be part of a shared resource
domain.

Workload Definition...

Create a monitored workload.

Logical Server...

Create a logical server (Windows CMS only).

Planning scenario...

Create new scenario screens. For more information see HPE Capacity Advisor
help.

Table 11 HPE Matrix OE visualization Modify menu
Menu selection

Description

Shared Resource Domain...

Modify the definition of a shared resource domain.

Workload Definition...

Edit properties of a monitored workload.

Logical Server

Edit properties of a logical server (Windows CMS only).

Logical Server Storage Pools...

Edit storage pools for use by logical servers (Windows CMS only).

Logical Server Portability Groups...

Edit properties of portability groups (Windows CMS only).

Logical Server Target Attributes...

Edit target attributes associated with logical servers (Windows CMS only).

→ Manage
→ Copy

Table 12 HPE Matrix OE visualization Delete menu
Menu selection

Description

Shared Resource Domain

Remove an SRD definition from the configuration.

Workload Definition(s)...

Remove an existing workload definition. You will be prompted to confirm the
deletion.

Delete Logical Server...

Remove a logical server (Windows CMS only).

Unmanage Logical Server...

Stop managing a logical server (Windows CMS only).
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Table 13 HPE Matrix OE visualization Configure menu
Menu selection

Description

Global Forecast...

Modify parameters in the HPE Capacity Advisor forecast model, which are
applied as the default in resource use trend displays in the profile viewer.

Global Utilization Limits...

Modify utilization limits for CPU and memory use, which are applied by default
to data in resource use displays and data tables in the profile viewer.

Workload Forecast...

Define a forecast model for workloads.

Workload Utilization Limits...

Define utilization limits for workloads.

Calibrate Power (All Selected Systems)...

Calibrate power for selected systems managed by HPE Matrix OE.

Edit Network and Disk I/O Capacity...

Set desired capacity for network and disk I/O bandwidth for selected systems.

Agentless Data Collection...

View systems with agentless data collection or use advanced options.

→ List Agentless Systems
→ Advanced Agentless Options
User Preferences

Modify some aspects of HPE Matrix Operating Environment for personal use.

The following table lists menu selections that you can use to manage policies defined in HPE
Global Workload Manager.
Table 14 HPE Matrix OE visualization Policy menu
Menu selection
Apply gWLM Policy...
Change Associated gWLM Policy...
Edit gWLM Policies...
Remove Associated gWLM Policy...
Create gWLM Policy...

Table 15 HPE Matrix OE visualization Report menu
Menu Selection

Description

gWLM Real-time Reports...

Monitor current interaction of workload activity and management policies.

gWLM Historical Reports

Create a report of historical workload activity.

gWLM Advanced Reports...

Create a report showing overall workload activity and to help identify workloads
that require more resources.

Capacity Planning

Create reports showing computing resource utilization, trends in usage, cost
allocation, and planning scenario comparisons.

Logical Server Job Status...

Create a report showing job status and messages for logical servers (Windows
CMS only).

View Logical Server Details...

Create a report that provides additional information for logical servers (Windows
CMS only).

HPE Matrix OE tool bar
The HPE Matrix OE visualization tool bar provides a convenient way to adjust the display of
compartment information. Figure 1 shows the HPE Matrix OE visualization toolbar options.

34

Getting started

Figure 1 HPE Matrix OE visualization tool bar options

1

2

The drop-down menu allows you to select different ways of visualizing your enterprise. The
default view is the “Physical and Virtual” view, which shows all physical and virtual servers
and the greatest number of nodes. You can select alternate views for server blades, logical
servers, Serviceguard clusters, or virtual machines; or show systems and events. In most
cases, selecting an alternate view limits the number of nodes displayed by restricting the
view to a particular type of node (“Virtual Machine”, for example). You can change the default
view that appears when you access HPE Matrix OE visualization by modifying your user
preferences. For more information, see the online help for user preferences.
Select the Show Workloads check box or Show Workloads button to the left of the check
box to display sub-OS workloads running on a given system. Workload compartments display,
when they exist. Click either tool bar element to clear the workloads from the display.
In the following figure, a workload running on a VSP is shown in the blue sub-compartment.
By default, this control is turned off; HPE Matrix OE visualization initially filters out workload
information from the compartment. For more information, see the online help for compartment
details.
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3

4

The tool bar expand and collapse buttons allow you to manage the extent of detail you
want shown in the compartments and sub-compartments. For information about how these
buttons work, see the online help for tool bar buttons.
The Search field allows you to locate a given system by searching for a compartment name.
When you enter the name in the search field, HPE Matrix OE visualization first highlights all
complete or partial matches of the name. When you click the Search button or press Enter,
HPE Matrix OE visualization moves the scroll bar to the first compartment name it matches.
For example, searching for the system citrine moves the scroll bar so the compartment for
that system is at the top:

For more information, see the online help for the tool bar search feature.
5

6

The Refresh button
allows you to update the display to include the latest compartments,
their relationships, and utilization information. Normally, refreshing the display is not necessary
because the view is updated automatically as new data becomes available. However, you
might use the Refresh button to reattempt gathering utilization data for all items to ensure
the view is showing the latest information. Refreshing the view updates all containers and
relationships, resource utilization data, authentication credentials (WBEM) from HPE Systems
Insight Manager, and workload information from HPE Global Workload Manager. While the
view refreshes, the Refresh button spins to indicate it is in progress.
Status errors or warnings when receiving data are indicated by an alert button. For example,
a warning will appear if a system lacks a valid license or if a license has expired. Multiple
alerts are indicated by the number displayed. Click the Alert button to view detailed
information about the error(s) or warning(s). An alert popup displays. Click the [X] button in
the upper right-hand corner of the popup to close it.

For more information, see the online help for alerts.

Customizing collections and home page
The following sections describe ways to customize HPE Systems Insight Manager to make it
more convenient to start HPE Matrix OE visualization and view the systems that you most
frequently manage.

Creating custom collections
In HPE Systems Insight Manager, you can create custom system collections whose default view
is set to any of the following options:
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•

HPE Matrix OE visualization—Makes the HPE Matrix OE visualization the default view for
the collection and opens with the “Physical and Virtual” perspective.

•

gWLM—Makes the Shared Resource Domain tab the default view for the collection.

•

HPE Matrix OE visualization (Logical Servers)—Makes HPE Matrix OE visualization the
default view for the collection and opens with the “Logical Server” perspective.
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•

HPE Matrix OE visualization (Blades)—Makes HPE Matrix OE visualization the default
view for the collection and opens with the “Blades” perspective.

•

HPE Matrix OE visualization (Virtual Machines)—Makes HPE Matrix OE visualization the
default view for the collection and opens with “Virtual Machines” perspective.

•

HPE Matrix OE visualization (Serviceguard)—Makes HPE Matrix OE visualization the
default view for the collection and opens with the “Serviceguard” perspective.

•

HPE Matrix OE visualization (collection nodes only)—Makes HPE Matrix OE visualization
the default view and opens with “Physical and Virtual” perspective, but only showing nodes
that are in that collection and that you explicitly have authorizations to view.
NOTE: Other HPE Matrix OE views might pull in authorized parent or child nodes not
explicitly defined in a collection.

Selecting a custom collection starts HPE Matrix OE visualization. Using a custom collection
instead of All Matrix OE Resources can provide significant performance improvements because
only the systems in your custom collection will be displayed.
To create a custom collection, use the following procedure:
1. From the Systems and Event Collections list in the left-hand navigation area, select the
Customize... link.
2. Click New... to create a new custom collection.
3. Use the radio button to choose whether to individually specify the systems in the collection
or select systems based on their attributes.
4. Specify the systems or the attributes of systems to be included in the collection, and, click
Save As Collection.
5. Specify the collection name and its location in the Systems tree, and then click OK.
NOTE: Non-administrators can only save collections under the Private collection, whereas
administrators can save them anywhere. Any collections intended for use with the default
collection preference must be saved directly under the All Matrix OE Resources collection.
6.
7.

8.

Select the radio button next to the newly created collection, and, click Set Properties.
From the Default View drop-down, selection one of the following:
•

HPE Matrix OE

•

gWLM

•

HPE Matrix OE (Logical Servers)

•

HPE Matrix OE (Blades)

•

HPE Matrix OE (Virtual Machines)

•

HPE Matrix OE (Serviceguard)

•

HPE Matrix OE (Collection Nodes Only)

Click OK.

For more information on Visualization views or perspectives, see the HPE Matrix Operating
Environment Visualization with Logical Servers Online Help.

Automatically displaying HPE Matrix OE visualization
You can customize HPE Systems Insight Manager so that your preferred perspective in HPE
Matrix OE visualization is automatically displayed as soon as HPE Systems Insight Manager
starts.
Use the following procedure to set your HPE Systems Insight Manager home page.
Using HPE Matrix OE visualization
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1.
2.
3.
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From the top menu bar, choose Options→Home Page Settings....
Select the option This collection and choose All Matrix OE Resources or another collection
from the menu.
Click OK.
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4 Troubleshooting
This chapter describes some of the tools and procedures that can be used to troubleshoot
problems in HPE Matrix Operating Environment. Additional troubleshooting information can be
found in the user guides listed in “Using HPE Matrix OE and related environments” (page 46).
For information about known issues and workarounds in this release, see the HPE Matrix
Operating Environment Release Notes available at Hewlett Packard Enterprise Information
Library.

Memory and other system requirements
Make sure that your CMS and managed systems meet the requirements specified in the HPE
Insight Management Support Matrix available at Hewlett Packard Enterprise Information
Library. In particular, note the recommended and minimum supported memory requirements.
If error messages about exceeding heap space are displayed, you may need to increase the
heap size of the HPE Systems Insight Manager Java Virtual Machine (JVM). On 64–bit systems,
Systems Insight Manager sets the heap size to 4096 MB (4 GB). You can specify a different
heap size by setting the JVMMAXHEAP value (in MB) in the globalsettings.props file. On
HP-UX, this file is at /etc/opt/mx/config/globalsettings.props. On Windows, it is at
installation-directory\config\globalsettings.props. The default installation
directory is C:\Program Files\HP\Virtual Server Environment, but this directory can
be changed at installation time.

HPE Insight managed system setup wizard
Many configuration issues can be avoided by using the managed system setup wizard to configure
managed systems for use with HPE Matrix OE. The wizard automates the installation of required
licenses, agent software, and other configuration settings to support the management capabilities
intended for use on the system.
To start the managed system setup wizard, select Configure→Managed System Setup Wizard...
from the top menu. Help is available in each step of the wizard.

Diagnose menu actions
There are three tasks available from the Diagnose→Troubleshoot Matrix Operating
Environment menu, described in the following sections. These tasks use the vseassist
command to perform configuration checks. For examples of the output from these checks, see
vseassist(1M) (page 51).

Check CMS configuration
This task performs a number of configuration checks on the CMS. When troubleshooting your
configuration, perform this task first. Once you have resolved any CMS configuration issues, you
can diagnose issues with specific managed systems using the “Check CMS to managed node
communication” (page 40) and “Check managed node configuration” (page 41) tasks described
below.
Procedure 9 Check the configuration of your CMS
1.
2.

From the top menu bar, select Diagnose→Troubleshoot Matrix Operating
Environment→Check CMS Configuration....
To schedule this task to run periodically or at a set time, click Schedule. The Schedule
Task screen is displayed. Help on scheduling options is available from that screen. After
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the task executes, you can view the results by selecting Tasks & Logs→View Task Results...
from the top menu bar.
To run this task immediately, click Run Now. This executes the vseassist command on
the CMS and displays the results in the Stdout tab.
3.

4.

For each check performed by this task, one of the following status indicators is displayed:
PASS

No configuration problem was found

FAIL

A serious configuration problem was found. You must resolve the problem for correct
operation of HPE Matrix Operating Environment.

WARN

A configuration problem was found. The problem will not necessarily prevent correct
operation of HPE Matrix Operating Environment, but it may limit or restrict operation of
some features.

N/A

Not Applicable: the check does not apply to this type of system.

Optional: To print a copy of the output, click View Printable Report, and then click Print.

This task writes detailed information to the log file (/var/adm/syslog/vseassist.log on
an HP-UX CMS, installation-directory\logs\vseassist.log on Microsoft Windows
systems). Check the log file for details of any problems encountered.
TIP: The vseassist command line that was executed by this task is displayed on this screen
above the output box. This command is also displayed in the printable version of the report. You
can use this information to create your own diagnostic scripts that can be run from the command
line.
You can review these results again later by selecting Tasks & Logs→View Task Results... from
the top menu bar.

Check CMS to managed node communication
This task checks the communication between the CMS and selected managed systems. When
troubleshooting your HPE Matrix OE configuration, perform the “Check CMS configuration”
(page 39) task first, to make sure that you do not have any unresolved CMS configuration issues.
Then use this task to resolve communication issues with managed systems where you are having
problems. Some of the problems detected with this option include expired licenses, no open
WBEM ports, and improperly configured SSH authentication. These checks will verify whether
the CMS can communicate with the managed systems in order to perform management functions.
Procedure 10 Check the communication between the CMS and managed systems
1.

2.
3.

4.
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Optional: Select the managed systems where you are having problems. You can select
systems by checking the selection box next to each system name in the HPE Matrix OE
visualization view. If you prefer, you can start this task with no systems selected. In that
case, you are prompted to select the systems from the available HPE SIM system collections
after the next step below.
Select Diagnose→Troubleshoot Matrix Operating Environment→Check CMS to Managed
Node Communication... from the top menu bar.
Optional: If no systems have been selected yet, you are prompted to select from the available
HPE SIM system collections. If you have already selected systems, then those systems are
displayed in the Verify targets screen. HPE Systems Insight Manager provides several
options for adding or removing systems on this screen. For help, select Help→For HPE
Systems Insight Manager from the top menu bar, then select the Operations topic and
the Managing with tasks subtopic.
To schedule this task to run periodically or at a set time, click Schedule. The Schedule
Task screen is displayed. Help on scheduling options is available from that screen. After
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the task executes, you can view the results by selecting Tasks & Logs→View Task Results...
from the top menu bar.
To run this task immediately, click Run Now. This executes the vseassist command on
the CMS and displays the results in the Stdout tab.
5.

6.

For each check performed by this task, one of the following status indicators is displayed:
PASS

No configuration problem was found.

FAIL

A serious configuration problem was found. You must resolve the problem for correct
operation of HPE Matrix OE.

WARN

A configuration problem was found. The problem will not necessarily prevent correct
operation of HPE Matrix OE, but it may limit or restrict operation of some features.

N/A

Not Applicable: the check does not apply to this type of system.

Optional: To print a copy of the output, click View Printable Report, and then click Print.

This task writes detailed information to the log file (/var/adm/syslog/vseassist.log on
HP-UX systems, installation-directory\logs\vseassist.log on Microsoft Windows
systems). Check the log file for details of any problems encountered.
TIP: The vseassist command line that was executed by this task is displayed on this screen
above the output box. This command is also displayed in the printable version of the report. You
can use this information to create your own diagnostic scripts that can be run from the command
line.
You can review these results again later by selecting Tasks & Logs→View Task Results... from
the top menu bar.

Check managed node configuration
This task checks the configuration of HP-UX, Microsoft Windows or Linux managed systems by
using mxexec to copy the vseassist command to selected managed systems, and remotely
execute it there. When troubleshooting your HPE Matrix OE configuration, perform the “Check
CMS configuration” (page 39) task first, to make sure that you do not have any unresolved CMS
configuration issues. Then use the “Check CMS to managed node communication” (page 40)
task to resolve communication issues with managed systems where you are having problems.
Once you have resolved the communication issues, use this task to resolve configuration issues
for any managed systems where you are still having problems.
Procedure 11 Check the configuration of managed systems
1.

2.
3.

4.

Optional: Select the managed systems where you are having problems. You can select
systems by checking the selection box next to each system name in the Visualization View.
If you prefer, you can start this task with no systems selected. In that case, you are prompted
to select the systems from the available HPE SIM system collections after the next step
below.
Select Diagnose→Troubleshoot Matrix Operating Environment→Check Managed Node
Configuration... from the top menu bar.
Optional: If no systems have been selected yet, you are prompted to select from the available
HPE SIM system collections. If you already selected systems, then those systems are
displayed in the Verify targets screen. HPE Systems Insight Manager provides several
options for adding or removing systems on this screen. For help, select Help→For HPE
Systems Insight Manager from the top menu bar, then select the Managing with tasks
topic.
To schedule this task to run periodically or at a set time, click Schedule. The Schedule
Task screen is displayed. Help on scheduling options is available from that screen. After
Diagnose menu actions
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the task executes, you can view the results by selecting Tasks & Logs→View Task Results...
from the top menu bar.
To run this task immediately, click Run Now. This executes the vseassist command on
the CMS and displays the results in the Stdout tab.
5.

6.

For each check performed by this task, one of the following status indicators is displayed:
PASS

No configuration problem was found.

FAIL

A serious configuration problem was found. You must resolve the problem for correct
operation of HPE Matrix OE.

WARN

A configuration problem was found. The problem will not necessarily prevent correct
operation of HPE Matrix OE, but it may limit or restrict operation of some features.

N/A

Not Applicable: the check does not apply to this type of system.

Optional: To print a copy of the output, click View Printable Report, and then click Print.

This task writes detailed information to the log file (/var/adm/syslog/vseassist.log on
HP-UX systems, installation-directory\logs\vseassist.log on Microsoft Windows
systems). Check the log file for details of any problems encountered.
TIP: The vseassist command line that was executed by this task is displayed on this screen
above the output box. This command is also displayed in the printable version of the report. You
can use this information to create your own diagnostic scripts that can be run from the command
line.
You can review these results again later by selecting Tasks & Logs→View Task Results... from
the top menu bar.

vseassist command
The vseassist command, which implements the Diagnose menu actions described in the
previous section, can also be executed directly from the command line on the CMS. If you are
unable to resolve communication issues with one of your managed systems, you can install or
copy this command to the managed system and run it from the command line there.
For details of the command line options, suggested diagnostic procedure, and examples, see
vseassist(1M) (page 51). On an HP-UX CMS, this reference page can also be viewed from the
command line using the man command.
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5 Support and other resources
Accessing Hewlett Packard Enterprise Support
•

For live assistance, go to:
Contact Hewlett Packard Enterprise Worldwide

•

To access documentation and support services, go to:
Hewlett Packard Enterprise Support Center

Information to collect
•

Technical support registration number (if applicable)

•

Product name, model or version, and serial number

•

Operating system name and version

•

Firmware version

•

Error messages

•

Product-specific reports and logs

•

Add-on products or components

•

Third-party products or components

Accessing updates
•

Some software products provide a mechanism for accessing software updates through the
product interface. Review your product documentation to identify the recommended software
update method.

•

To download product updates, go to either of the following:

•

◦

Get connected with updates from HPE page.

◦

Software Depot home page.

To view and update your entitlements, and to link your contracts and warranties with your
profile, go to More Information on Access to HPE Support Materials page:
IMPORTANT: Access to some updates might require product entitlement when accessed
through the Hewlett Packard Enterprise Support Center. You must have an HP Passport
set up with relevant entitlements.

Websites
Website

Link

Hewlett Packard Enterprise Information Library

www.hpe.com/info/enterprise/docs

Hewlett Packard Enterprise Support Center

www.hpe.com/support/hpesc

Contact Hewlett Packard Enterprise Worldwide

www.hpe.com/assistance

Subscription Service/Support Alerts

www.hpe.com/support/e-updates

Software Depot

www.hpe.com/support/softwaredepot

Customer Self Repair

www.hpe.com/support/selfrepair
Accessing Hewlett Packard Enterprise Support
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Website

Link

Insight Remote Support

www.hpe.com/info/insightremotesupport/docs

Serviceguard Solutions for HP-UX

www.hpe.com/info/hpux-serviceguard-docs

Customer self repair
Hewlett Packard Enterprise customer self repair (CSR) programs allow you to repair your product.
If a CSR part needs to be replaced, it will be shipped directly to you so that you can install it at
your convenience. Some parts do not qualify for CSR. Your Hewlett Packard Enterprise authorized
service provider will determine whether a repair can be accomplished by CSR.
For more information about CSR, contact your local service provider or go to the CSR website:
Customer Self Repair

Remote support
Remote support is available with supported devices as part of your warranty or contractual support
agreement. It provides intelligent event diagnosis, and automatic, secure submission of hardware
event notifications to Hewlett Packard Enterprise, which will initiate a fast and accurate resolution
based on your product’s service level. Hewlett Packard Enterprise strongly recommends that
you register your device for remote support.
For more information and device support details, go to the following website:
Hewlett Packard Enterprise Information Library

Security bulletin and alert policy for non-Hewlett Packard Enterprise
owned software components
Open source software (such as OpenSSL) or third-party software (such as Java) are sometimes
included in Hewlett Packard Enterprise products. Hewlett Packard Enterprise discloses that the
non-Hewlett Packard Enterprise owned software components listed in the HPE Insight
Management end user license agreement (EULA) are included with HPE Insight Management.
The EULA is included with the HPE Insight Management Installer on HPE Insight Management
DVD #1.
Hewlett Packard Enterprise addresses security bulletins for the software components listed in
the EULA with the same level of support afforded Hewlett Packard Enterprise products. Hewlett
Packard Enterprise is committed to reducing security defects and helping you mitigate the risks
associated with security defects when they do occur.
When a security defect is found, Hewlett Packard Enterprise has a well defined process that
culminates with the publication of a security bulletin. The security bulletin provides you with a
high level description of the problem and explains how to mitigate the security defect.

Registering for software technical support and update service
HPE Insight Management includes one year of 24 x 7 Hewlett Packard Enterprise Software
Technical Support and Update Service. This service provides access to HPE technical resources
for assistance in resolving software implementation or operations problems.
The service also provides access to software updates and reference manuals in electronic form
as they are made available from Hewlett Packard Enterprise. Customers who purchase an
electronic license are eligible for electronic updates.
With this service, HPE Insight Management customers benefit from expedited problem resolution
as well as proactive notification and delivery of software updates. For more information about
this service, see the following website:
HP Foundation Care Services
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Registration for this service takes place following online redemption of the license certificate.

How to use your software technical support and update service
As Hewlett Packard Enterprise releases updates to software, the latest versions of the software
and documentation are made available to you. The Software Updates and Licensing portal gives
you access to software, documentation and license updates for products on your Hewlett Packard
Enterprise software support agreement.
You can access this portal from the Hewlett Packard Enterprise Support Center:
Hewlett Packard Enterprise Support Center
After creating your profile and linking your support agreements to your profile, see the Software
Updates and Licensing portal at Hewlett Packard Enterprise Software Updates Support to
obtain software, documentation, and license updates.

HPE authorized resellers
For the name of the nearest Hewlett Packard Enterprise authorized reseller, see the following
sources:
•

In the United States, see the Hewlett Packard Enterprise U.S. service locator website:
Find a Partner

•

In other locations, see the Contact Hewlett Packard Enterprise worldwide website:
Contact HPE Support Worldwide

Related information
For information about open-source products included with HPE Matrix Operating Environment
(including license constraints, updates, and security information), see the end-user license
agreement included with HPE Matrix Operating Environment. This document is installed on the
CMS at the following locations:
HP-UX CMS
/opt/vse/src/README
Microsoft Windows CMS

installation-directory\src\README
The default installation directory is C:\Program Files\HP\
Virtual Server Environment, but this directory can be
changed at installation time.

Manuals and white papers
The latest versions of manuals and white papers for HPE Matrix OE and related products can
be downloaded from the Hewlett Packard Enterprise Web. The manuals and white papers listed
below can be found at the location:
NOTE: This link refers to an external resource outside of this help system. Your browser must
have access to the Internet to use this link.
Hewlett Packard Enterprise Information Library
The following tables list the manuals and white papers that are available. Some documents
appear in multiple tables.

HPE authorized resellers
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Installation and configuration: Microsoft Windows CMS
Topic

Document

Requirements, feature support,
compatibility

• HPE Insight Management Support Matrix

Release notes

• HPE Matrix Operating Environment Release Notes
• HPE Insight Control Release Notes
• HPE Virtual Connect Enterprise Manager Release Notes

Installation and configuration

• HPE Insight Management Installation and Configuration Guide
• HPE Insight Management Preinstallation Worksheet
• HPE Insight Management Quick Installation Guide

Installation and configuration: HP-UX CMS
Topic

Document

Requirements, feature support,
compatibility

• HPE Insight Management Support Matrix

Release notes

• HPE Matrix Operating Environment Release Notes

Installation and configuration

• HPE Matrix Operating Environment Integrity CMS Installation and Configuration
Guide

Using HPE Matrix OE and related environments
Topic

Document

Getting started

• HPE Matrix Operating Environment Getting Started Guide (this document)
• HPE Insight Management Getting Started Guide
• HPE Insight Control Getting Started Guide

User guides

• HPE Matrix Operating Environment Logical Server Management User Guide
• HPE Capacity Advisor User Guide
• Application Discovery User Guide
• HPE Global Workload Manager User Guide
• HPE Integrity Virtual Server Manager User Guide
• HPE Insight Control Server Migration User Guide
• HPE Insight Control Virtual Machine Management User Guide
• HPE Insight Control Performance Management User Guide
• HPE Storage Provisioning Manager (SPM) User Guide
• HPE Matrix Operating Environment Infrastructure Orchestration User Guide
• HPE Insight Control Power Management User Guide
• HPE Matrix Operating Environment Recovery Management User Guide
• HPE Virtual Connect Enterprise Manager User Guide

White papers
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Visit the Hewlett Packard Enterprise Information Library.

Websites
NOTE: These links refer to external resources outside of this help system. Your browser must
have access to the Internet to use these links.

Information and solutions
Reference Architectures for
Application Deployment in
Virtualized Environments

http://www.hpe.com/info/idvsera

Hewlett Packard Enterprise Support Hewlett Packard Enterprise Support Center
Center
Large Enterprise Business

http://www.hpe.com/info/enterprise

Products
HPE Matrix Operating Environment http://www.hpe.com/helion/cloudsystemmatrix
HPE Insight Management

http://www.hpe.com/info/insightmanagement

HPE Insight Control

http://www.hpe.com/info/insightcontrol/

HPE Virtual Connect Enterprise
Manager

http://www.hpe.com/info/vcem/

HPE Systems Insight Manager

http://www.hpe.com/servers/hpsim/

HPE CloudSystem Matrix

http://www.hpe.com/info/matrix

Command references (manpages)
HPE Matrix Operating Environment and related products include manpages for HP-UX and Linux
systems and command reference pages for Microsoft Windows systems. These pages provide
details about commands, file formats, and related information. See “Command reference”
(page 50) for command reference pages included with this document. The following tables list
additional reference pages related to HPE Matrix OE.

Reference pages installed on the CMS
Reference page

Description

capagentlesscfg(1M)

Set advanced options for HPE Capacity Advisor agentless data collection, and view a list of
systems configured for agentless data collection (Windows CMS only)

capcustombenchmark(1M)

Configure HPE Capacity Advisor benchmark CPU scaling to normalize collected data

capcustombenchmark(4)

Format of HPE Capacity Advisor custom benchmark database files

capovpaextract(1M)

Export HPE Performance Management Agent (formerly HPE OpenView Performance Agent,
or OVPA) system data from managed systems and import into Capacity Advisor

cappmpextract

Export HPE Insight Control performance management system data from specified managed
systems and import the data into HPE Capacity Advisor (Windows CMS only)

capprofile(1M)

Import, export, display, invalidate and remove HPE Capacity Advisor data for workloads or
systems

capprofile(4)

Format of HPE Capacity Advisor import and export files

capupgrade(1M)

Recomputes the CPU utilization data after a HPE Systems Insight Manager upgrade

gwlm(1M)

HPE Global Workload Manager

gwlm(5)

Overview of HPE Global Workload Manager

gwlmcmsd(1M)

HPE Global Workload Manager daemon
Related information
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Reference page

Description

gwlmreport(1M)

Produce advanced textual summary reports for workload resource utilization

gwlmsslconfig(1M)
gwlmimportkey(1M)
gwlmexportkey(1M)

Secure network communications for HPE Global Workload Manager

msswinitconfig(1M)

Configure or unconfigure the Insight managed system setup wizard

gwlmxml(4)

Overview of XML file structure for HPE Global Workload Manager

vseassist(1M)

Help resolve HPE Matrix OE configuration problems

vseinitconfig(1M)

Configure or unconfigure the HPE Matrix OE software

vselicense(1M)

Manage licenses to use (LTUs) on HPE Integrity and HP 9000 systems

Reference pages installed with agent software on managed systems
Reference page

Description

agent_config(1M)

Control Application Discovery certificates from the managed node

amgrd(1M)

Control or modify the operation of the Application Discovery agent

gwlmagent(1M)

HPE Global Workload Manager (gWLM) agent

gwlmplace(1M)

Place a process in a gWLM workload

gwlmsend(1M)

Send metric data to gWLM for use in a custom policy

gwlmsslconfig(1M)
gwlmimportkey(1M)
gwlmexportkey(1M)

Secure network communications for HPE Global Workload Manager

gwlmstatus(1M)

Display status for the managed node's agent, SRD and license manager

utild(1M)

(HP-UX) system utilization data collection daemon

utild(8)

(Linux) system utilization data collection daemon

UPService.pdf

(Windows) Utilization Provider Service (document installed in \Program Files\
Hewlett-Packard\UtilProvider\doc)

Reference page installed on cell-based complexes
Reference page

Description

parmgr(1M)

Start Partition Manager

Reference pages installed on systems running HPE Integrity VM
Reference page

Description

hpvm(5)

About HPE Integrity VM

hpvmclone(1M)

Create a cloned copy of an HPE Integrity VM virtual machine

hpvmcollect(1M)

Collect crash dumps, logs, system status, and configuration on guests and the HPE Integrity
VM Host

hpvmconsole(1M)

Connect to the console of an HPE Integrity VM virtual machine

hpvmcreate(1M)

Create a new Integrity VM virtual machine
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Reference page

Description

hpvmdevmgmt(1M)

Manage the HPE Integrity VM device database

hpvminfo(1M)

Display information about the HPE Integrity VM environment

hpvmmodify(1M)

Rename or modify the attributes of an HPE Integrity VM virtual machine

hpvmmigrate(1M)

Move a virtual machine to another HPE Integrity VM Host system

hpvmnet(1M)

Configure virtual network devices

hpvmremove(1M)

Remove an HPE Integrity VM virtual machine

hpvmstart(1M)

Start an HPE Integrity VM virtual machine

hpvmstatus(1M)

Display status of one or more HPE Integrity VM virtual machines

hpvmstop(1M)

Stop an HPE Integrity VM virtual machine

Selected HPE Systems Insight Manager reference pages
Reference page

Description

mxagentconfig(1M)

Configure the agent to work with a CMS

mxauth(1M)

Add, remove or list authorizations in HPE Systems Insight Manager

mxglobalsettings(1M)

Manage global settings in HPE Systems Insight Manager

mxinitconfig(1M)

Perform initial configuration of the server

mxnode(1M)

Add, modify, identify, remove or list nodes in HPE Systems Insight Manager

mxstart(1M)

Start HPE Systems Insight Manager and the TomCat webserver

mxstatus(1M)

Display or return (via exit code) the current ready/not-ready state of HPE Systems Insight
Manager

mxstop(1M)

Stop HPE Systems Insight Manager and the TomCat webserver

mxuser(1M)

Add, modify, remove or list users in HPE Systems Insight Manager

Documentation feedback
Hewlett Packard Enterprise is committed to providing documentation that meets your needs. To
help us improve the documentation, send any errors, suggestions, or comments to Documentation
Feedback (docsfeedback@hpe.com). When submitting your feedback, include the document
title, part number, edition, and publication date located on the front cover of the document. For
online help content, include the product name, product version, help edition, and publication date
located on the legal notices page.

Documentation feedback
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vseassist(1M)
NAME
vseassist -- Help Resolve HPE Matrix OE Configuration Problems

SYNOPSIS
Path (HP-UX): /opt/vse/bin/vseassist
Path (Windows): install-path\bin\vseassist.exe
Usage:
vseassist -a [-q] [ -n nodename | -g collectionname ]...
vseassist -c [-q]
vseassist { -l | -r } [-q] { -n nodename | -g collectionname }...
vseassist -s [-q] -h cmsfqdn
vseassist -v

DESCRIPTION
The vseassist command performs a number of checks to identify configuration problems in
your installation of HPE Matrix Operating Environment. This command checks the software
configuration on the HPE SIM Central Management Server (CMS), the communication between
the CMS and managed systems, and the configuration of the software on managed systems. A
summary of results is displayed and detailed results are written to a log file, along with
recommendations for resolving any problems found.
You can execute vseassist from the HPE Matrix OE graphical user interface, from the command
line on the CMS, or from the command line on a managed system. Hewlett Packard Enterprise
recommends the following diagnostic procedure:
1. If you have Administrator (root) access to the CMS, execute the following command from
the command line:
vseassist -a
This will check the configuration of the CMS, communication with all systems in the All
Matrix Resources collection, and the configuration on those systems. Refer to the summary
output and examine the log file for any problems. Follow the resolution steps in the log file
to fix any problems that were found.
Fix problems in the CMS configuration first. You can verify that you have fixed those problems
by executing the following command from the CMS command line:
vseassist -c
You can also run this command directly from the HPE Matrix OE user interface. From the
Diagnose menu, select Troubleshoot Matrix Operating Environment, then select Check
CMS Configuration.
2.

After you have resolved all problems with the CMS configuration, check to see if there are
any remaining communication issues with the managed systems. From the CMS command
line, specify the HPE SIM nodenames or system collection names of your managed systems
using the following command:
vseassist -l { -n nodename | -g collectionname ...}
Or, from the HPE Matrix OE user interface, select the managed systems, then from the
Diagnose menu, select Troubleshoot Matrix Operating Environment, then select Check
CMS to Managed Node Communication.

3.

After you have resolved the communication issues between the CMS and your managed
systems, check the configuration on those systems. From the CMS command line, specify
the HPE SIM nodenames or system collection names of your managed systems using the
following command:
vseassist -r { -n nodename | -g collectionname ...}
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Or, from the HPE Matrix OE user interface, select the managed systems, then from the
Diagnose menu, select Troubleshoot Matrix Operating Environment, then select Check
Managed Node Configuration.
4.

If you are unable to resolve issues with one of your managed systems, you can install or
copy vseassist to the managed system and run it from the command line there. In the
following command, replace cms with the fully qualified domain name of the CMS:
vseassist -s -h cms

Options
If no options are specified, the command syntax is displayed and the command exits with return
code 3.
The vseassist command recognizes the following options. For each option, a mnemonic is
shown in parentheses to help you remember the option letter.
-a
(All) Perform all checks:
1. Check the configuration of the CMS (as with the -c option).
2. Check the communication between the CMS and the specified
managed systems (as with the -l option). If no managed systems
are specified, then perform this check on all systems in the All
Matrix Resources collection.
3. Check the configuration of the specified managed systems (as
with the -r option). If no managed systems are specified, then
perform this check on all compatible systems in the All Matrix
Resources collection.
-c

(CMS) Check the configuration of the CMS.
NOTE:
For a Windows CMS, if IOAssist is installed, additional
IOAssist resource and CMS configuration checks will be launched.

-l

(Link) From the CMS, check the communication between the CMS
and the managed systems specified by the -n and -g options. Some
of the problems detected with this option include expired licenses,
no open WBEM ports, and improperly configured SSH authentication.
These checks will verify that the CMS can communicate with the
managed systems in order to perform management functions.
This option requires one or more -n or -g options.
NOTE: On Windows and HP-UX CMS, vseassist will obtain the
port on which to attempt managed node communication from the file
globalsettings.props (see FILES section below). If no port
configuration is present, port 22 will be used.
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-r

(Remote) From the CMS, check the configuration of the HP-UX or
Windows managed systems specified by the -n and -g options
(vseassist does not provide configuration checks for Linux
managed systems). This option uses mxexec to copy the vseassist
command to the managed systems, where it is executed with the -s
option.
In order for the -r option to succeed, the CMS must be able to
communicate with the managed systems (as checked by the -l
option).
This option requires one or more -n or -g options.

-n nodename

(Node) Specifies the name of a managed system using the node
name by which the system is known to the CMS (as reported by
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mxnode(1M)). Multiple -n and -g options can be used to specify
multiple systems.
NOTE: This command is only designed to diagnose problems with
systems that are part of the All Matrix Resources collection.
Applying this command to other resources using -n or -g options
will not produce useful results.
-g collectionname

(Group) Specifies the name of a collection of systems known to the
CMS. The specified checks will be performed for each of the managed
systems in the collection. Multiple -n and -g options can be used to
specify multiple systems.
NOTE: System or collection names that include spaces must be
enclosed in quotes.
Refer to mxquery(1M) for more information about collections under
HPE SIM.

-q

(Quiet) No output will be generated on stdout or stderr. The results
will still be logged to the vseassist.log file.

-s

(System) This option is used when running vseassist directly on
HP-UX or Windows managed systems (vseassist does not provide
configuration checks for Linux managed systems). Some of the
problems detected with this option include missing WBEM providers,
stalled WBEM process, and missing required patches. On an HP-UX
managed system, WBEM services checks will be performed by
wbemassist if wbemassist version 1.1 or later is installed. Otherwise
vseassist will use its own built-in WBEM checks.
NOTE: Note: wbemassist checks for problems in HP-UX WBEM
Services and recommends solutions. It does not perform checks on
WBEM Providers or other services that use the CIM server. For more
information, see wbemassist(1M).
When you use vseassist with the -r option on the CMS, mxexec
will remotely execute vseassist on the managed systems using
the -s option.

-h cms

(Host) Specifies the fully qualified domain name of the CMS that is
managing the system. This option is passed to the remote execution
of vseassist when you use the -r option on the CMS.

-v

Displays vseassist version

Installation
The vseassist command is installed on the CMS when HPE Matrix OE is installed.

RETURN VALUES
0
1
2
3
4

The command completed successfully and no FAIL results were found.
The command completed successfully and one or more FAIL results were found.
Warnings, but no FAIL results were found.
Incorrect options were specified; the command syntax is displayed.
An unexpected internal error occurred. Contact your Hewlett Packard Enterprise Support
Representative, your Hewlett Packard Enterprise Services Representative, or your authorized
Hewlett Packard Enterprise reseller for assistance.
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EXAMPLES
The specific checks performed may vary by operating system and system type of the CMS and
managed systems. The following examples show the kind of output that is produced, but the
details may be different in your environment.
Check the configuration of a CMS named unixsys:
# vseassist -c
Version: 7.6
+-----------------------------------------------------------------------------------------------+
|
Performing CMS configuration verification
|
+-----------------------------------------------------------------------------------------------+
unixsys:
HPE SIM running.........................................................................[PASS]
HPE SIM memory configuration............................................................[PASS]
HPE Matrix Operating Environment running................................................[PASS]
Localhost name resolution..............................................................[PASS]
Matrix OE manageable systems discovered in HPE SIM......................................[PASS]
Application Discovery server running...................................................[PASS]
File system free space.................................................................[PASS]
Java JRE installed.....................................................................[PASS]
Virtual Machine Management runnning....................................................[PASS]
VMM responsive.........................................................................[WARN]
WARNING:
HP SIM has discovered one or more virtual machine hosts
servers, but the VMM plugin is not fully configured to
manage the following servers: palacio .
RESOLUTION: - Verify if the HPE Management Agents are installed (for
SNMP and proper HPE SIM discovery);
- Verify if VMM agent has been installed; It's possible to
install that via the "Deploy -> Deploy Drivers,
Firmwares and Agents -> Install VMM Agent" menu;
- Verify if the system is licensed for VMM;
- Verify if the system is registered for VMM, if not
register the VM host via the "Configure -> Virtual
Machine Host Registration" menu or register the VM via
the native virtualization console and Identify the
system using "Options->Identify Systems" menu.
Virtual Connect Enterprise Manager responsive.........................................[PASS]
Logical Server Automation installed...................................................[PASS]
Running infrastructure orchestration (IO) Checks......................................[PASS]
Result Summary:
13 verification check(s) performed on 1 system(s)
12 check(s) passed
0 check(s) failed
1 check(s) warned
0 check(s) not applicable
See log for details: C:\Program Files\HP\Virtual Server Environment\logs\vseassist.log

Check the communication from the CMS to the managed system named system:
# vseassist -l -n system
Version: 7.6
+---------------------------------------------------------------------------------------------+
|
Performing link verification of managed system(s) from the CMS
|
+---------------------------------------------------------------------------------------------+
system:
Managed system hostname resolution...................................................[PASS]
WBEM port open.......................................................................[PASS]
WBEM authentication..................................................................[PASS]
SSH port open........................................................................[PASS]
SSH authentication...................................................................[PASS]
SNMP port open.......................................................................[PASS]
Trial or permanent license applied...................................................[PASS]
VMM accessibility....................................................................[N/A ]
Capacity Advisor data collection.....................................................[PASS]
Check VMware ESX version.............................................................[N/A ]
Result Summary:
8 verification check(s) performed on 1 system(s)
8 check(s) passed
0 check(s) failed
0 check(s) warned
2 check(s) not applicable
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See log for details: C:\Program Files\HP\Virtual Server Environment\logs\vseassist.log

AUTHORS
vseassist was developed by Hewlett-Packard Company.

DOCUMENT LAST UPDATED
December 2013

MESSAGES
The following message may be displayed when running managed system configuration checks
on a 64-bit Windows managed system:
'chcp' is not recognized as an internal or external command,
operable program or batch file.

This is an issue with the remote command execution facility of HPE SIM. The message can be
ignored.

FILES
Configuration settings, including communication port settings, are read from the following file:
HP-UX:
/etc/opt/mx/config/globalsettings.props
Windows:

install-path\config\globalsettings.props

Detailed results of the checks performed by vseassist are written to the log file. Examine the
log file for recommended steps to resolve any problems found.
NOTE:

Note: The log file is not automatically pruned.

HP-UX:

/var/adm/syslog/vseassist.log

Windows:

install-path\logs\vseassist.log

Linux:

/var/log/vseassist.log

The default install-path on a Windows CMS is C:\Program Files\HP\Virtual Server
Environment, but this directory can be changed at installation time.

SEE ALSO
HPE Matrix Operating Environment Online Help
mxexec(1M), mxnode(1M), mxquery(1M), vseinitconfig(1M), vselicense(1M), wbemassist(1M)
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vselicense(1M)
NAME
vselicense -- Manage licenses to use (LTUs) on HPE Integrity and HPE 9000 Systems

SYNOPSIS
Path (HP-UX): /opt/vse/bin/vselicense
Path (Windows): installation-directory\bin\vselicense
vselicense { -? | --help }
(Show command help)
vselicense --usage
(Show command syntax)
vselicense { -t | --tempLicense } { -n sys | --sys=sys }...
(Apply temporary trial licenses)
vselicense { -l key | --key=key } { -n sys | --sys=sys }... { -p prod |
--prod=prod }
(Migrate and apply Integrity Windows/Linux LTUs)
vselicense { -m | --migrate } [ -g | --gwlm ] { -n sys | --sys=sys }...
(Scan and migrate HP-UX LTUs)
vselicense { -m | --migrate } { -c count | --count=count } { -n sys |
--sys=sys }
(Correct the number of per-core/socket licenses assigned to a system)
vselicense { -m | --migrate } { -c 0 | --count=0 } { -n sys | --sys=sys }
(Remove all the licenses applied to a system)
vselicense { -s | --show }
(List the managed systems with migrated LTUs)

DESCRIPTION
The vselicense command is installed on the Central Management Server (CMS) with HPE
Matrix OE. This command installs and removes Licenses to Use (LTUs) for HPE Matrix Operating
Environment for HP-UX. It can also be used to correct the number of per-core or per-socket
licenses that are applied for LTUs.
This command applies only to HPE Integrity systems running HP-UX, Linux, or Microsoft Windows
operating systems, and HP 9000 systems running HP-UX. It is not used for licenses based on
“5x5” keys (introduced with VSE Management Software version 4.0). It is only used for trial
licenses included with HPE Matrix OE and for the LTUs in the following list. You may have these
LTUs installed from a previous version of HPE Matrix Operating Environment, or from the HP-UX
VSE or DC Operating Environments.
T2786AC HPE VSE Suite for HP-UX 11i LTU
T2784AC HPE Capacity Advisor for HP-UX LTU
T2782AC HPE Virtualization Manager for HP-UX LTU
T2762AA HPE Global Workload Manager Agent LTU
T2807AC HPE Capacity Advisor for Integrity Windows
T2806AC HPE Virtualization Manager for Integrity Windows
T2785AC HPE Capacity Advisor for Integrity Linux
T2783AC HPE Virtualization Manager for Integrity Linux
HPE Matrix OE licenses are now managed in the HPE Systems Insight Manager License Manager
database on the CMS. These licenses are encoded in a “5x5” key consisting of 5 blocks of 5
numbers or characters. These licenses are added to the CMS and applied to managed systems
through HPE SIM.
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Licenses from previous versions of the software and licenses included in the HP-UX VSE or DC
Operating Environments are automatically migrated to the License Manager database if they
were previously in use (the license had already been installed and scanned). If these licenses
were never installed or have not yet been scanned, you may be able to migrate them to License
Manager database using vselicense (see “Migrating previously unused licenses” below).

Correcting the number of licensed cores or sockets
HPE Matrix OE for Integrity products are licensed per core or socket on managed HPE Integrity
and HP 9000 systems. When licenses from a previous release or from the HP-UX Operating
Environments are migrated to the current version, the number of cores or sockets on the managed
system is determined via a WBEM query. The value returned is used as the number of licenses
assigned to that system. If the WBEM query is unsuccessful at determining the correct number,
one license is assigned.
You are responsible for verifying that the correct number of licenses are applied to your managed
systems, based on the number of cores or sockets in use. In order to remain in compliance with
your End User Licensing Agreement, you may need to correct the count assigned during the
license migration process. To correct the count assigned during migration, enter the following
command on the CMS:
vselicense -m -c count -n sys

where count is the correct number of per-core or per-socket licenses to assign for system sys.

Migrating previously unused licenses
If permitted by your licensing agreement with Hewlett Packard Enterprise, unused licenses that
were purchased for an earlier release but have not yet been installed or scanned can be migrated
to the License Manager database and applied to a managed system by the vselicense
command, using the following procedures. These procedures should also be used to enable the
LTUs included with the HP-UX VSE or DC Operating Environments.
To scan for HP-UX LTUs to migrate and apply, follow the steps below. (This scan can also be
performed by the Insight managed system setup wizard and from the HPE Matrix OE GUI.)
1. Install the HP-UX LTUs that have unused licenses, or install the VSE or DC Operating
Environment, on the managed system.
2. Establish common WBEM credentials for communication between the CMS and the managed
systems, or configure SSH for use in HPE SIM. In some previous versions of the software,
SSH was required in order to scan for HP-UX LTUs. This scan is now attempted using
WBEM. SSH will only be used if scanning via WBEM fails. For information about configuring
WBEM credentials and SSH, see the HPE Matrix Operating Environment Integrity CMS
Installation and Configuration Guide available at Hewlett Packard Enterprise Information
Library.
It is also possible to scan for the gWLM LTU (T2762AA) by communicating directly with the
gWLM agent if it is running on the managed system. However, this will provide no information
about the other LTUs. To perform this type of scan, use the -g or --gwlm option.
NOTE: The gWLM scanning option is only supported for gWLM agent versions earlier
than version 4.0.
3.

Execute one of the following commands on the CMS (note that multiple -n sys options
can be specified):
•

Scan for T2786AC, T2784AC, T2782AC, and T2762AA LTUs using WBEM or SSH:
vselicense -m -n sys

•

Scan for T2762AA LTU by communicating with the running gWLM agent:
vselicense -m -g -n sys
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NOTE:
4.

This operation may take a long time to complete.

If necessary, correct the number of per-core or per-socket licenses assigned to the systems
using vselicense with the -m and -c options, as described above.

To migrate and apply unused HPE Integrity Linux or HPE Integrity Windows LTUs, follow these
steps:
1. Execute the following command on the CMS (note that multiple -n sys options can be
specified):
vselicense -l key -n sys -p prod

where key is the license key provided with the LTU product prod.
NOTE:
2.

This operation may take a long time to complete.

If necessary, correct the number of per-core or per-socket licenses assigned to the systems
using vselicense with the -m and -c options, as described above.

NOTE: Changes made by vselicense may not show up in the product's user interface until
you refresh the data (click the Refresh Data link in Capacity Advisor, or the Refresh Data icon
in the Visualization tab).
After migration to the License Manager database, your previously purchased LTUs will appear
in the HPE SIM License Manager under the following new license names:
HPE Matrix OE for Integrity
Migrated from:
T2786AC HPE VSE Suite for HP-UX 11i LTU
HPE Matrix OE visualization

Migrated from:
T2782AC HPE Virtualization Manager for HP-UX LTU
T2806AC HPE Virtualization Manager for Integrity Windows
T2783AC HPE Virtualization Manager for Integrity Linux

HPE Capacity Advisor

Migrated from:
T2784AC HPE Capacity Advisor for HP-UX LTU
T2807AC HPE Capacity Advisor for Integrity Windows
T2785AC HPE Capacity Advisor for Integrity Linux

HPE Global Workload Manager
(gWLM)

Migrated from:
T2762AA HPE Global Workload Manager Agent LTU

Use the HPE SIM License Manager to view the status of these licenses (select Deploy ->
License Manager... from the HPE SIM menu, then select one of the new license names, as
shown in the preceding list).

Options
The vselicense command recognizes the following options:
-t|--tempLicense
Apply a trial license for HPE Matrix OE for Integrity to the
systems identified by the -n options. When HPE Matrix OE
is installed on the CMS, 10 trial licenses for HPE Matrix OE
for Integrity are included in the License Manager database.
These licenses can be applied to HPE Integrity and HP 9000
systems. Each trial license is valid for 90 days after it is applied
to a managed system. To continue to manage these systems
beyond the trial period, permanent licenses must be
purchased.
-l key|--key=key
Install the license key for the LTU product identified by the
-p option on the systems identified by the -n options.
-n sys|--sys=sys
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The system name, as identified in HPE SIM.

NOTE: HPE Integrity virtual machines are licensed through
the VM Host. You cannot specify a virtual machine as the
target of a vselicense command. Instead, apply the
command to the VM Host system.
-p prod|--prod=prod

-g|--gwlm

-m|--migrate
-c count|--count=count

-s|--show

The product number of the LTU being installed or migrated.
For example, T2783AC is the product number for the
Virtualization Manager LTU for HPE Integrity managed
systems running Linux.
Communicate directly with the gWLM agent running on the
managed system when scanning for the gWLM LTU. This
option should only be used if WBEM and SSH are not
configured for use. When using this option, the scan can only
detect the gWLM LTU (T2762AA). No information will be
returned about other LTUs. This option is only supported for
gWLM agent versions earlier than version 4.0.
Migrate LTUs to the HPE SIM License Manager database.
Set the number of per-core or per-socket licenses to apply to
the system identified by the -n option. This option is only valid
for previously migrated LTUs on the specified system. A
count value of 0 removes all migrated LTUs for that system
from the License Manager database.
List the managed systems that have licenses that have been
migrated from previous software releases.

RETURN VALUES
0
1
2

The command completed successfully; no errors were detected.
An error occurred and the command did not complete successfully.
A warning occurred. See command output for details.

EXAMPLES
Apply licenses for the HPE Virtualization Manager for Integrity Linux (product T2783AC) on the
managed system that is identified in HPE SIM as linsys1. The key value was obtained from
Hewlett Packard Enterprise when the LTU was purchased.
vselicense -l key -n linsys1 -p T2783AC

Apply licenses for LTUs installed on an HP-UX managed system named uxsys2. The command
uses WBEM (or SSH if WBEM scan fails) to scan for the LTU(s) installed on the system.
vselicense -m -n uxsys2

Use gWLM to scan and apply T2762AA licenses on an HP-UX managed system.
vselicense -m -g -n uxsys3

Correct the number of per-core or per-socket licenses to 4 for a system with previously migrated
licenses.
vselicense -m -c 4 -n uxsys2

Remove all the licenses that were previously migrated and assigned to the managed system
winsys4.
vselicense -m -c 0 -n winsys4

AUTHORS
vselicense was developed by Hewlett-Packard Company.
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SEE ALSO
Additional information is available in the License Management topic of the HPE Matrix OE help,
the “Reference pages installed on the CMS” (page 47) and in the following documents:
vseinitconfig(1M), HPE Matrix Operating Environment Integrity CMS Installation and Configuration
Guide, HPE Insight Management Installation and Configuration Guide
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Glossary
active logical
server

A logical server that has been bound to both a managed system in HPE Systems Insight Manager
and a workload, and is bound to specific storage. Active logical servers can be in one of two
states: powered on or powered off. An active logical server can be moved from one location to
another and its characteristics can be modified.

agent

A program that regularly gathers information or performs some other service without the user's
immediate presence.

application

A logically related set of processes active on a system (a running application) and/or a logically
related set of files on a machine disk (an installed application).

BladeSystem

The Hewlett Packard Enterprise product portfolio of blade form factor computing devices that
provide versatile computing configurations, integrated network connectivity, and power
management capabilities. BladeSystem options are available in both the Integrity and ProLiant
product lines.
See also BladeSystem enclosure, BladeSystem Integrated Manager.

BladeSystem
enclosure

Hardware solution that provides a flexible selection of half- or full-size server blades and
associated components (such as integrated connectivity to storage and data networks, and
shared power subsystems) into a single unit.
See also BladeSystem Integrated Manager.

BladeSystem
Integrated
Manager

A software component in Systems Insight Manager that enables users to navigate the blade
servers, enclosure infrastructures, racks, and integrated switches in their BladeSystem
environment by way of pictorial and hierarchical tree representations.

callout icons

Graphical icons that display in the right-hand corner of compartments or subcompartments.
Information callout icons show the system or workload attributes. Meter callout icons show
expanded information about the utilization meters that appear to the left of the icon. The utilization
meters display the recent utilization metrics for CPU, memory, disk, and LAN. See HPE Matrix
OE visualization with Logical Servers Online Help for explanation of icons appearing on the
Visualization tab.

cell

A circuit board that contains processors and memory, all controlled by a cell controller (CC). A
cell is the basic building block of an nPartition in a complex.

cell-based server

A server in which all cores and memory are contained in cells, each of which can be assigned
for exclusive use by an nPartition. Each nPartition runs its own instance of an operating system.

CMS

Central Management Server. A system in a server management domain that runs HPE Systems
Insight Manager (SIM). All central operations within HPE SIM are initiated from this system.

compartment

An nPartition, virtual partition, virtual machine, or resource partition for which resources are
allocated by HPE Global Workload Manager (gWLM).
Multiple compartments are grouped to form a shared resource domain (SRD). The compartments
all share the resources of the SRD. A compartment can be in only one SRD. Each compartment
holds a workload. gWLM manages each workload's resource allocation by adjusting the resource
allocation of its compartment.
On the HPE Matrix OE Visualization tab, compartments are represented by color. You can
select the entire compartment or individual members within a compartment, then select a
drop-down menu item to operate on the selected item.

complex

A complex includes one or more cabinets that are cabled together and all of the hardware
resources that they contain. A complex has a single service processor.

core

The actual data-processing engine within a processor. A single processor might have multiple
cores, and a core might support multiple execution threads.

FSS group

Fair-Share Scheduler group. A group of processes that has its CPU allocation managed by the
HP-UX Fair Share Scheduler. FSS groups allow you to allocate fractions of cores, rather than
only whole cores, to the processes in the group.

GiCAP

HPE Global Instant Capacity. Software that enables you to move usage rights for HPE Instant
Capacity components within a group of servers.
See also iCAP, TiCAP.
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HPE SPM

HPE Storage Provisioning Manager, a service-oriented storage provisioning solution bundled
with HPE Matrix OE.

HPE VCEM

HPE Virtual Connect Enterprise Manager. A management tool for defining a server connection
profile for each server bay. This profile establishes the media access control (MAC) addresses
for all network interface controllers (NICs), the World Wide Names (WWNs) for all host bus
adapters (HBAs), and the SAN boot parameters. If the server blade in the server bay is replaced,
the configuration and connection profile stays constant.

iCAP

HPE Instant Capacity. The product allows you to purchase and install additional processing
power through the use of a two-step purchase model. Initially, you purchase system components
(cores, cell boards, memory) at a fraction of the regular price because the usage rights are not
included. These Instant Capacity components are inactive but installed and ready for use. When
extra capacity is needed, you pay the remainder of the regular price for the usage rights to
activate the components. If the regular price for the component is reduced by the time the usage
rights are purchased, the remainder price is proportionally reduced, providing additional savings.
See also GiCAP, TiCAP.

logical server

A logical server is the complete software image of a server, including operating system,
applications, configuration data, and metadata that you create and assign to operate on a
physical server or virtual machine. Logical servers simplify the provisioning, management, and
movement of servers; and they allow you to quickly populate an enclosure, load balance servers,
and evacuate servers in case of disaster. Using logical servers, you can provision resources
only when needed, increasing optimal utilization of limited compute resources. Logical servers
are a feature of the HPE Matrix Operating Environment.
See also active logical server.

LTU

License to use.

managed
instance

A resource that is managed via a public cloud service provider. These resources are represented
as Cloud Resources inside and can be added to a server pool in the same way as any other
VM Host or ESX Resource Pool.

managed system

A server or other system that can be managed and monitored by HPE Insight Management
software from an HPE Systems Insight Manager CMS. A system can be managed and monitored
by more than one CMS.

managed
workload

A workload that is managed by HPE Global Workload Manager.

management
domain

A CMS and its managed systems.

monitored
workload

A workload that can be monitored by the HPE Matrix Operating Environment, but has no policy
associated with it. Monitored workloads are not managed by HPE Global Workload Manager.

nPartition

A partition in a cell-based server that consists of one or more cells and one or more I/O
components. Each nPartition operates independently of other nPartitions and either runs a
single instance of an operating system or is further divided into virtual partitions.
nPartitions can be used as compartments managed by HPE Global Workload Manager (gWLM)
as long as several requirements are met. For a descriptino of nPartition requirements, see the
HPE Global Workload Manager Online Help.
See also virtual partition.

parked workload

A workload that is not currently associated with a system. A workload becomes parked if its
system is set to “none” when it is created or later modified. A parked workload that was previously
associated with a system may have historical data associated with it from HPE Capacity Advisor
or HPE Global Workload Manager. As with any workload, the historical data is lost if the workload
is deleted.
When migrating a workload from one system to another, it may be useful to park the workload
(removing the association with the original system) until the new system becomes available.
This preserves the historical data for the workload across the migration.
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partition

1.

A subset of server hardware that includes core, memory, and I/O resources on which an
operating system (OS) can be run. This type of partitioning allows a single server to run
an OS independently in each partition with isolation from other partitions.
2. A resource partition, made up of either a Fair-Share Scheduler (FSS) group or a processor
set, that runs within a single OS. This type of partitioning controls resource allocations
within an OS.
See also nPartition, virtual partition.

policy

A collection of rules and settings that control compute resources For example, an HPE Global
Workload Manager (gWLM) policy can indicate the minimum and maximum amount of CPU
resources allowed for a workload, and a target to be achieved.
A single policy can be associated with multiple workloads.

provision

A function that makes a component operational. Provisioning might include installing, upgrading,
loading, and configuring a software or hardware component. Provisioning a server includes
loading the appropriate software (operating system and applications), customizing and configuring
the system, and starting the server and its newly-loaded software. This makes the system ready
for operation.

PSET

Processor set. A collection of processors grouped together for exclusive access by applications
assigned to that processor set. Each application runs only on processors in its assigned
processor set.

Public cloud
bursting

A feature of HPE Matrix OE that enables enterprises to broker service delivery across multiple
clouds from a single, integrated point of control.

resource
partition

A subset of the resources available to an operating system instance, isolated for use by specific
processes. A resource partition has its own process scheduler. CPU resources in the partition
may be allocated using Fair-Share Scheduler groups or processor sets. Policies for controlling
the allocation of resources to the partition can be set using HPE Global Workload Manager.

server blades

Thin, modular, self-contained computer servers, containing one or more microprocessors and
memory. Server blades are designed for high density and eliminate many components such
as power cords and network cables that are present in traditional rack-mount systems.
See also BladeSystem enclosure.

service
processor

An independent support processor for Hewlett Packard Enterprise servers that support
nPartitions. The service processor provides a menu of service-level commands, plus commands
to reset and reboot nPartitions and configure various parameters.
The service processor in Hewlett Packard Enterprise servers is sometimes called the
management processor (MP) or the guardian service processor (GSP).

Serviceguard
cluster

An HPE Serviceguard cluster is a networked group of HPE 9000 or HPE Integrity servers (host
systems known as nodes) having sufficient redundancy of software and hardware that a single
point of failure will not significantly disrupt service.

Serviceguard
package

Packages are the means by which HPE Serviceguard starts and halts configured applications.
A package is a collection of services, disk volumes and IP addresses that are managed by
Serviceguard to ensure they are available.

Serviceguard
workload

A monitored workload associated with a Serviceguard cluster and a particular package within
the cluster. The workload (and the utilization data reported) follows the package it is associated
with as it moves between the nodes of the cluster.

SMI-S

Storage Management Initiative Specification. SMI-S delivers open storage network management
interface technology in order to have “all storage managed by the SMI interface” as the unifying
factor between all objects that must be managed in a storage area network and the tools used
to manage them.

socket

(CPU socket). The physical chip carrier on the circuit board that houses a CPU chip. The CPU
may consist of multiple cores.

SRD

Shared resource domain. A collection of compartments that share system resources managed
by HPE Global Workload Manager (gWLM). The compartments can be nPartitions, virtual
partitions, virtual machines, processor sets (PSETs) or Fair-Share Scheduler (FSS) groups.
A server containing nPartitions can be an SRD as long as nPartition requirements are met.
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A server or an nPartition divided into virtual partitions can be an SRD for its virtual partition
compartments. A VM Host can be an SRD to its virtual machines. Similarly, a server, an
nPartition, or a virtual partition containing PSETs can be an SRD for its PSET compartments.
Finally, a server, an nPartition, or a virtual partition containing FSS groups can be an SRD for
its FSS-group compartments.
A complex with nPartitions can hold multiple SRDs. For example, if the complex is divided into
nPartitions named Par1 and Par2, Par1's compartments could be virtual partitions, while Par2's
compartments are PSETs.
SSL

Secure Sockets Layer. Protocol for validating identity and for creating an encrypted connection
between a server and a Web browser.

system

1.
2.

A server, nPartition, virtual partition, or virtual machine that is running an instance of an
operating system.
Entities on the network that communicate through TCP/IP or IPX. To manage a system,
some type of management protocol (for example, SNMP, DMI or WBEM) must be present
on the system. Examples of systems include servers, workstations, desktops, portables,
routers, switches, hubs and gateways.

TiCAP

Temporary Instant Capacity. An Hewlett Packard Enterprise product that enables customers
to purchase prepaid core activation rights for a specified (temporary) period of time. Temporary
capacity is sold in 30 processing-day increments.
See also GiCAP, iCAP.

Utilization
Provider

The WBEM services provider for real-time utilization data from managed systems.

virtual machine

A software entity provided by HP Integrity Virtual Machines, VMware ESX, VMware ESXi, or
Microsoft Hyper-V. This technology allows a single server or nPartition (with Integrity Virtual
Machines) to act as a VM Host for multiple individual virtual machines, each running its own
instance of an operating system (referred to as a guest OS). Virtual machines are managed
systems in the HPE Matrix Operating Environment.

virtual partition

A software partition of a server, or of a single nPartition, where each virtual partition can run its
own instance of an operating system. A virtual partition cannot span an nPartition boundary.
See also nPartition, virtual machine.

VM Host

A server running HP Integrity Virtual Machines, VMware ESX, VMware ESXi, or Microsoft
Hyper-V, that provides multiple virtual machines, each running its own instance of an operating
system.

vPars

An Hewlett Packard Enterprise software product that provides virtual partitions.
See also virtual machine.

vPars monitor

The program that manages the assignment of resources to virtual partitions in a vPars-enabled
system. To enable virtual partitions, the vPars monitor must be booted in place of a normal
HP-UX kernel. Each virtual partition running under the monitor then boots its own HP-UX kernel.
See also VM Host.

WBEM

Web-Based Enterprise Management. A set of web-based information services standards
developed by the Distributed Management Task Force, Inc. A WBEM provider offers access
to a resource. WBEM clients send requests to providers to get information about and access
to the registered resources.
See also Utilization Provider.

WMI

Windows Management Instrumentation. HPE Matrix Operating Environment uses WMI for data
collection from managed systems running Microsoft Windows. WMI queries and responses are
converted to WBEM through the WMI Mapper.

workload

A collection of processes in a standalone server, nPartition compartment, virtual partition
compartment, or virtual machine compartment. HPE Global Workload Manager (gWLM) extends
this concept to include processor set (PSET) compartments and Fair-Share Scheduler (FSS)
group compartments.
See also managed workload, monitored workload, Serviceguard workload.
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accessing
updates, 43
agent
removing unneeded agents, 28
agentless data collection, 28
configuring credentials, 26
Analysis tab, 31
authorizations
setting, 22
user, 26

glossary, 61
gWLM see Global Workload Manager

C
capacity planning, 7–8
Central Management Server see CMS
CMS, 5
check CMS configuration, 39
check CMS to managed node configuration, 40
HP-UX CMS installation, 25
memory requirements, 39
troubleshooting, 39
Windows CMS installation, 25
command
reference pages, 47
vseassist, 42, 51
vselicense, 56
communication
troubleshooting, 39
configuration
check CMS configuration, 39
check CMS to managed node configuration, 40
check managed node configuration, 41
managed system setup wizard, 21, 25, 39
contacting Hewlett Packard Enterprise, 43
customer self repair, 44

D
data collection
credentials required, 26
HPE Capacity Advisor service, 26
solving problems, 27
Diagnose menu, 39
disaster recovery, 10
documentation
providing feedback on, 49

H
HP-UX Operating Environments, 22
HPE Application Discovery, 10
HPE Capacity Advisor, 5, 7
scenario, 7
HPE Capacity Advisor Consolidation Software, 8
HPE Global Workload Manager, 11
HPE Global Workload Manager (gWLM), 5
HPE Insight Control, 5
HPE Insight Management, 5–6
HPE Instant Capacity, 11, 20
HPE Instant Capacity Manager, 5
HPE Instant Capacity software, 5
HPE Integrity Virtual Server Manager, 5, 12
HPE Matrix OE
Configure menu, 34
Create menu, 33
Delete menu, 33
Modify menu, 33
Policy menu, 34
Report menu, 34
tabs, 31
Tools menu, 33
HPE Matrix OE licenses
for HPE Capacity Advisor Consolidation software, 19
for HPE Integrity servers, 19
for HPE ProLiant servers, 18
for public cloud, 23
for trial licenses, 20
HPE Matrix OE logical server management, 7
HPE Matrix OE visualization, 5–6
HPE Matrix OE visualization tool bar
options, 34
HPE Matrix Operating Environment infrastructure
orchestration, 5
HPE Matrix Operating Environment recovery
management, 5
HPE SIM see Systems Insight Manager
HPE Storage Provisioning Manager, 10
HPE Systems Insight Manager
customizing for HPE Matrix OE visualization, 36
HPE Virtual Connect Enterprise Manager, 5, 7

E
event notification
data collection errors, 27

F
features
HP-UX CMS, 16
Windows CMS, 15

I
infrastructure orchestration, 8
installation
HP-UX CMS, 25
Windows CMS, 25

L
license
adding and applying, 21
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and HPE Instant Capacity products, 20
applying with License Manager, 21
applying with managed system setup wizard, 21
configuration, 12
EULA, 17
HP-UX Operating Environments, 22
Integrity, 22
License Manager, 21
managed instance model, 23
managed system model, 17
management, 17
migration from earlier release, 22
order to apply on Windows managed systems, 22
scan for HP-UX licenses, 22
trial, 20
License Manager, 21
starting, 22

M
managed instance, 23
managed system
check CMS to managed node configuration, 40
check managed node configuration, 41
supported configuration, 12
troubleshooting, 39
managed system setup wizard, 21, 25, 39
using to apply licenses, 21
manpage, 47
manuals, 45
Matrix OE licenses
for HPE Instant Capacity products, 20
limited license for HPE Operations Orchestration, 20
Matrix OE menu bar, 31
memory requirements, 39
metrics
configuring utilization measures to reflect your
environment, 27

P
Partition Manager, 11
Planning tab, 31
platform, 12
PowerBroker, 25
privilege elevation, 25
provisioning
infrastructure, 8
storage, 10
public cloud bursting, 23

R
recovery management, 10
related information, 45
remote command execution, 25
remote support, 44
requirements
memory, 39
root access, 25

66

Index

S
Shared Resource Domain tab, 11, 31
SIM
starting Matrix OE visualization , 30
SPM see Storage Provisioning Manager
sub-OS workload, 29
sudo, 25
support
Hewlett Packard Enterprise, 43

T
tabs
in HPE Matrix OE, 31
tool bar options, 34
troubleshooting, 39

U
updates
accessing, 43
upgrade from earlier release, 28
user authorizations, 26
Utilization Provider, 28

V
virtual machine
managing, 12
visualization
automatic display of favorite collection, 37
Visualization tab, 31
Visualization View
HPE Matrix OE visualization tool bar, 34
vseassist, 42, 51
vselicense, 56

W
websites, 43, 47
customer self repair, 44
white papers, 45
workload
sub-OS workloads removed on upgrade, 29
Workload tab, 31

